0
$\begingroup$

I have an ATI Radeon HD 5800 Series graphics card and all the latest drivers installed, including the latest APU drivers that now come packed with the AMD catalyst software...

I am using Blender 2.76, which is the latest version of blender as of this post.

How do I get Compute to work on my computer?

Compute device settings in user preferences

The only option I get is CPU...

If anyone can help it would be most appreciated, Happy blending guys and girls!

$\endgroup$
0
$\begingroup$

EDIT I thought I'd fixed my issue but if you see the next EDIT after this remark I was mistaken

Okay I fixed my issue... I needed to remove all traces of the old drivers...

Then reinstall them by going to the AMD website and downloading the auto-detect utility and running it.

I read it very carefully and before installing the graphics card drivers, there is a note at the top of the app stating that it don't install chipset drivers so I did that first and was prompted to restart the machine.

I Then relocated the auto-detect utility and proceeded to install the graphics drivers followed by the APU drivers (found on AMD.com) also.

Everything seems to be working nicely now and I have a new option in the user preferences;

OpenCL Option now available! Yay!

I am now rendering a complex scene and see notable improvements in speed!

EDIT:

It seems that support at this stage is only partial for lower grade AMD graphics cards... namely only GCN cards are supported and blender will hang if you change to cycles and change the setting from CPU to GPU Compute in the render tab.

Image of what not to do for those of us with lame but powerful graphics cards

Its rather convoluted and this behaviour should be blocked! I reported it as a bug but the devs are very busy and seem to think its a report and not a bug so we will have to put up with it until they discover it and fix it themselves.

This seems unlikely to happen because they all use powerful computers, so the message here is get better hardware because they don't care about bugs that effect older hardware...

lesson to be learnt... If you don't have the means, you won't discover that till you waste your time after not having any way of knowing it (unless your omniscient).

Lets just hope that they include support for older architecture graphics cards in the future because older graphics cards still have quite a lot of raw processing power and would increase confidence for disgruntled users like me that feel they don't have a voice!

$\endgroup$
  • $\begingroup$ It's not a Blender issue (besides giving you the option for OpenCL compute). AMD simply doesn't support most compute features with your card. As for "lesson to be learnt... If you don't have the means, you won't discover that till you waste your time after not having any way of knowing it (unless your omniscient)." A google search for "cycles supported video cards" leads to this page which flat out says HD5000 cards are not supported: blender.org/manual/render/cycles/gpu_rendering.html $\endgroup$ – JtheNinja Dec 14 '15 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.