4
$\begingroup$

Is it possible to scale an object and have it's scaled self snap to another object's edge or vertex?

Attached is a screenshot of what I'm trying to do: I want to scale the object on the left, and have it grow until it butts exactly against the object on the right. (In the picture, the object has grown too much by the time snap is activated). thanks

enter image description here

$\endgroup$
  • 1
    $\begingroup$ as alternative: you select the face of the right object, set cursor to selected, 3d cursor as pivot point, then selected the face of the left object, scale x to 0 $\endgroup$ – Faceb Faceb Oct 13 '15 at 15:18
  • $\begingroup$ The problem with that is that entire left object scales to zero in the x-dimension, unless I'm missing something. $\endgroup$ – RoyM Oct 13 '15 at 15:48
  • $\begingroup$ only select the face of the left object you would like to move $\endgroup$ – Faceb Faceb Oct 13 '15 at 15:49
  • $\begingroup$ I did select, but still get the weird behavior. Wondering if it's something in my user settings. I'm in 2.76, btw $\endgroup$ – RoyM Oct 13 '15 at 17:45
4
$\begingroup$

What you may do is to enable the Snapping Tool, change the snapping type to Vertex, then scale your object along the X axis (S,X) until it snaps to the other object. Then change the Y and Z parameters of Scale in Transform panel to the same as X has (hover the cursor over the X value window, hold LMB and drag it down to copy the X value to other windows). enter image description here

Before scaling an object make sure you snapped your 3D Cursor to its origin point (select an object in Object Mode, then press Shift+S-->Cursor to Selected). Also the pivot center type has to be set to 3D Cursor.
enter image description here

$\endgroup$
  • $\begingroup$ Gonzou - I'm following your steps, and still have the issue. If you can point me to how you created the animated gif, I'll make one and show the issue. I'm in 2.76. $\endgroup$ – RoyM Oct 13 '15 at 17:45
  • $\begingroup$ @RoyM, maybeif you use edit mode and select that face you want to move, G , and use the method mentioned here $\endgroup$ – Faceb Faceb Oct 13 '15 at 17:51
  • $\begingroup$ @RoyM To make a .gif you may use a LICEcap application. It can can capture an area of your desktop and save it directly to .GIF. Here's a download link: cockos.com/licecap BTW It's a really great app, which as I heard is recommended by gandalf3, the master himself :). $\endgroup$ – Paul Gonet Oct 13 '15 at 18:03
  • $\begingroup$ @RoyM On your attached screenshot I see, that you haven't snapped the cursor to the origin point of scaled object. See my updated answer. It should work for you now. $\endgroup$ – Paul Gonet Oct 13 '15 at 18:29
  • $\begingroup$ @Gonzou: I've uploaded a short screencast that shows my issue. youtube.com/watch?v=2ncY-kkyC4A $\endgroup$ – RoyM Oct 14 '15 at 16:10
2
$\begingroup$

Thank you all, for the generous help. I downgraded to blender 2.69 and there were no issues with snap. So I can confirm that 2.75 is buggy when it comes to snap. I should add that the 2.75 I used is from the the ppa at https://launchpad.net/~thomas-schiex/+archive/ubuntu/blender

correction to the above: It is indeed a bug, even in 2.69; snap on scale works for simple cases, but after a few operations, it appears to stop working properly. I filed a bug report, and it was fixed promptly (Thanks, Blender team!). The fix is of course, only in master at the moment.

update: I just pulled blender-edge (61646-d307c24-0thomas~trusty0) from the ppa, and yes! the bug is fixed.

$\endgroup$
  • $\begingroup$ Snap tool still broken. No difference in daily builds. They do not care about..... $\endgroup$ – user18864 Oct 18 '15 at 12:30
  • $\begingroup$ Campbell is the developer, I'm just the user - but my thought is: could you include a .blend that shows the issue you're having. $\endgroup$ – RoyM Oct 18 '15 at 15:46
1
$\begingroup$

I looked at your blend file.

  1. You have a moved origin, must be into object.
  2. You need change pivot point from 3D cursor to individual origin.
  3. You really need blender 2.75, because there is a problem with snapping tool in the latest release. I tried that yesterday, and I was very disappointed because snapping tool doesn't work as "well" like 2.75 or previous releases.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.