2
$\begingroup$

i want to animate this scene with falling leaves using the particle system but they are not transparent for some reason. (you can still see the wireframe and on a darker background it seems to be black where it should be transparent) but why?! enter image description here

i'm using the internal blender renderer in viewport they look exactly as i want them to. here are my material and texture settings: enter image description here

$\endgroup$
  • 1
    $\begingroup$ and here is my .blend file: sta.sh/0xjz7yszt7v $\endgroup$ – blutmond Oct 12 '15 at 23:11
  • 2
    $\begingroup$ Your file is missing the textures. Can you pack them on the file and re-upload it? $\endgroup$ – user1853 Oct 12 '15 at 23:56
  • $\begingroup$ oh sorry, i hope this one is with textures now: sta.sh/0jug701p3v4 $\endgroup$ – blutmond Oct 13 '15 at 18:16
1
$\begingroup$

Those are Freestyle outlines. If you don't want them you can turn Freestyle off in the Render tab of the Properties panel. Or, if you want them but you don't want them on those particular meshes, you can add a Material stroke modifier under the Properties panel->Render Layers tab->Freestyle Line Style->Alpha. Then set the Freestyle stroke alpha to zero in the leaf material. Or, you can model the leaf shape more accurately and stop using alpha on that material entirely. This would help a lot with the problems you're having with the mist, too, and I would personally recommend that you model the silhouette of the leaf a little more meticulously to help with that.

$\endgroup$
  • $\begingroup$ thank you! i will model the silhouette more accurately to avoid that problem because when i turn off freestyle the black background is still there. anyways, i wanted to ask where exactly to set the Freestyle stroke alpha to zero in the leaf material because i cannot find it? :D $\endgroup$ – blutmond Oct 13 '15 at 18:30
  • $\begingroup$ It should show up on the Material tab of the Properties panel, under Freestyle Line. On Blender Internal it was way on the bottom for me, on Cycles it was towards the top above Preview. $\endgroup$ – Spencer Brown Oct 17 '15 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.