0
$\begingroup$

I am trying to animate a beer glass moving across a table. I am using a particle emitter for the bubbles. My problem is that the emitted particles don't move with the beer but just continue to rise where they were emitted from thereby moving outside of the glass. Is there a way to have the generated particles move with the emitter and keep the same xy position of the emitter but still moving upward in z?

$\endgroup$
  • $\begingroup$ The easiest way to do this would be to use hair particles. If you're not familiar with this method here's a good tutorial (it's about making grass but the principles are the same): blenderguru.com/tutorials/… $\endgroup$ – TLousky Oct 12 '15 at 8:35
4
$\begingroup$

Thanks for the answers, but you may have misunderstood my question. You can't use hair because hair doesn't continually emit and what I needed was for particles to emit while moving with their emitter. Like when you pick up your beer glass, the bubbles stay in the beer instead of in the place where they formed.

I did figure out how to make it work and the answer is using keyed particles. with Keyed particles, you can create chains of emitters whose particles flow from emitter to emitter. With this you can create some really cool effects too. https://www.blender.org/manual/physics/particles/physics/keyed.html

To use,first set up your primary emitter. This will be the emitter whose particles are visible. Then duplicate that emitter and move it to where you want your particles to travel to. Then back on the first emitter, change the physics to "Keyed". then under that is a list where you can set keys. Click the button twice to add two keys. Select the second key and then select the second emitter on the object target below the keys.

enter image description here

Now set your second emitter to "Keyed" and particles to not render and run the simulation. Your particles now travel from emitter to emitter regardless of gravity. Parent the second emitter to the first and now they travel together. I found the answer on this youtube video https://www.youtube.com/watch?v=6tRKFUEhEgw

enter image description here

$\endgroup$
1
$\begingroup$

No, by default, if the emitter moves, the particles should be emitted always from it position, so the newest should appear from the current emitter position, "following" it (thus creating particle "trails").

But you could be seeing "cached" particles from a previous animation... try to "free all bakes" under "particles" tab. There you see also how many frames you have in memory. To cache to disk, you need the .blend to be saved as a file before.

enter image description here

The manual says "Emitter systems use a unified system for caching and baking (together with softbody and cloth). The results of the simulation are automatically cached to disk when the animation is played, so that the next time it runs, it can play again quickly by reading in the results from the disk. If you Bake the simulation the cache is protected and you will be asked when you’re trying to change a setting that will make a recalculating necessary."

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.