17
$\begingroup$

One click of the scroll wheel zooms too much IMO. Is there a way I can get more precision zooming?

$\endgroup$

4 Answers 4

21
$\begingroup$

CtrlMiddle Click is for precise zooming.

$\endgroup$
6
  • 2
    $\begingroup$ TIP: Ctrl + Middle Click works well in Uv/Image Editor also. $\endgroup$
    – Paul Gonet
    Oct 11, 2015 at 20:44
  • $\begingroup$ With an object selected (or any vertices, edges or faces selected in Edit Mode) press Z to zoom to that selection. Then when you zoom with the scroll wheel, the camera will zoom in relation to the size of your selection. It's not as precise as Ctrl Middle Click, but it works pretty well. $\endgroup$
    – YoeyYutch
    Oct 13, 2015 at 2:05
  • $\begingroup$ @YoeyYutch Z is for toggling between solid and wireframe view. Could you be thinking of Numpad . and you changed the hotkey to Z? $\endgroup$ Oct 13, 2015 at 15:09
  • $\begingroup$ Sorry I must have changed my keyboard shortcut. I thought it was default because I've seen video tutorials which use Z to 'zoom to selected'. $\endgroup$
    – YoeyYutch
    Oct 13, 2015 at 22:49
  • $\begingroup$ @YoeyYutch Okay. Do you use the normal version of Blender or do you use something like the Sensei Format? In that case you might just be thinking of some of those tutorials. $\endgroup$ Oct 14, 2015 at 17:11
1
$\begingroup$

I know it's an old post, but I just had the same issue and I didn't find a solution online. So I leave a solution here in case someone needs it still. I started having issues after pressing Shift+C to reset my 3D cursor in my scene. So I experimented with the Edit -> Preferences and "Navigation" tab. Under the "Orbit & Pan" section you have a tickbox for "Depth" that needs to be selected to get a more precise scroll-wheel zoom.

$\endgroup$
1
$\begingroup$

Straight to the point:: try hitting decimal on the NumPad '.' or whatever you have [Frame Selected] -- in certain modes without what I'll call a 'reference frame' it is trying to zoom you across 1000m of world space.

I found my way here because I had the same problem---however it was all of a sudden from no where; I was in sculpt mode on a regular cube object; and the mouse wheel was jumping football fields----I messed with settings I scoured preferences for something that might have changed---and then it struck me! - Like lots of things in blender (sculpting) Zooming can be relative. For my issue---I had not set any 'focus' to the cube; as soon as I hit '.' on the NumPad (decimal) which is mapped by default to [Frame Selected] then the planets aligned, the stars shone brighter and I found my mind again after it had begun slipping away... Hope this helps you &/or anyone else

$\endgroup$
0
$\begingroup$

Split the screen in two, change one view to camera view , 0 and the other to side view, 1, then select the camera in object mode and press g then z to precisely move the camera to where you want it.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .