4
$\begingroup$

I created an object, and I wanted it to glow. I used to just place points of light around it, and parent them to it, but using the emit option in the materials seemed so much easier. But when I gave it an a higher emit than 0, it went only a small distance before the light stopped. I turned it up to 200, and the object was white with light, but the light didn't go any farther. Oh and I changed the color, and nothing happened.

$\endgroup$
  • $\begingroup$ I'm going to recommend that you use Cycles instead of Blender Internal. When you start using Indirect lighting, you're essentially trying features that where added on because they where new. Blender Internal was never built for Indirect lighting and correct reflections. Cycles was build with these in mind, so it achieves better results at about the same speed, or faster. Especially if you get a good GPU or have a good CPU. $\endgroup$ – TARDIS Maker Oct 11 '15 at 1:06
  • $\begingroup$ OK... I was afraid of that. I got a couple rigs for my first animation (I'm starting with Minecraft animations, because I really like Minecraft and it seemed a good way to start) And they all used Blender Internal. So I'll have to retexture/remodel everything for this. I knew I was going to have to do that eventually, I just wanted some more practice with it overall before I made it, so I had an idea on what I need. I'm glad this place is here and active so I'm not going it completely alone. $\endgroup$ – BookWyrm17 Oct 11 '15 at 1:12
  • $\begingroup$ You'll just have to learn about the materials. The textures will go across pretty easily. Yeah, we're here and ready to help you out when you need it. $\endgroup$ – TARDIS Maker Oct 11 '15 at 1:15
  • $\begingroup$ Thank you! Really quick, before I have to go for tonight, (I don't think this warrents a whole post), how do I chat? I have twenty rep, but it says I "need twenty reputation before I can chat" and I don't see a place to type. $\endgroup$ – BookWyrm17 Oct 11 '15 at 1:16
  • 1
    $\begingroup$ It might take a bit for the rep to sync up. If you can't get it to work today, try tomorrow. $\endgroup$ – TARDIS Maker Oct 11 '15 at 1:31
3
$\begingroup$

To get this kind of interaction in Blender render you'll have to enable Indirect lighting with the Approximate Gather method.

From the Blender Reference Manual's page:

Indirect Lighting only works with Approximate gather method.

enter image description here

The emission color of the emitting object's surface comes from the diffuse color multiplied by the emission strenght (Emit).

enter image description here

$\endgroup$
  • $\begingroup$ Using indirect lighting with BI does increase render times a decent amount though, right? $\endgroup$ – TARDIS Maker Oct 11 '15 at 0:50
  • $\begingroup$ Yes, it does. The engine has more things to calculate. $\endgroup$ – Carlo Oct 11 '15 at 0:53
  • $\begingroup$ Oh. Wait. So I've had the indirect lighting activated for a while... But the question for me is "How do I increase the distance of the light" Right now it only goes a short distance, no matter how much I increase the emit. I want it to illuminate a large area. $\endgroup$ – BookWyrm17 Oct 11 '15 at 0:54
  • $\begingroup$ @BookWyrm17 My answer was completely irrelevant then. Sorry I misunderstood the question. $\endgroup$ – TARDIS Maker Oct 11 '15 at 0:56
  • $\begingroup$ Increase the strenght as you were doing. It should work. $\endgroup$ – Carlo Oct 11 '15 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.