0
$\begingroup$

So I'm having some issues with GPU rendering particles. I'm new at this and have created a pretty big scene with a decent amount of particles and image textures. When it starts rendering it renders the cabin, but once it starts rendering the particles of the landscape my GPU usage goes crazy. About an hour into the render I get a CUDA error and the rendering stops. I looked it up and it's supposedly an error that the memory is all used up, but MSI Afterburner shows the VRAM as only about half used up. I updated Blender and my drivers today and haven't had a chance to see if I still get the error, but my GPU usage is still all wonky once the particles start to get rendered.

Here is an example I quickly put together. On the left is a pretty simple project rendered. The GPU usage fluctuates a bit, but no errors or anything. On the right is the big project. You can see at the beginning it is just rendering the cabin and it's obvious when the particles start to be rendered because of the crazy GPU fluctuation. enter image description here

I had someone online render it with a Titan X and they said there was no issues and it took about 4 hours with 600 samples and 1080p. Here is the finished product that they saved the screenshot of. Still needs some work, but this is the full render that I haven't been able to see. enter image description here

and here is the blend file. It's big! https://drive.google.com/file/d/0B8smgBA_H8ClV01pMVpDSEkwYk0/view?usp=sharing

I appreciate any help. Thanks!

$\endgroup$
  • $\begingroup$ maybe splitting the rendering in different layers might help: blenderguru.com/articles/… $\endgroup$ – user1853 Oct 10 '15 at 17:26
  • $\begingroup$ In my system with only 3Gb of Vram (2 gtx780) your scene rendered fine i.stack.imgur.com/OqNiD.jpg . Try reinstalling the drivers for the GPU... and restoring to factory settings (on a similar memory management issue that was the fix for me) blenderartists.org/forum/… $\endgroup$ – user1853 Oct 10 '15 at 19:20
  • 1
    $\begingroup$ Also, as a side note, on your file the textures are quite large, and that will eat up a lot of your memory (read:blender.stackexchange.com/questions/27690/… ) . You don't need the textures to be larger than the size they will occupy on the final render. I.E. A texture that is 3888 pixels wide for an object that will be 50 pixels in the final image is indeed a waste of resources unless you are going to get too close to that particular object. Something else you can try is working with a smaller tile size in the performance settings. $\endgroup$ – user1853 Oct 10 '15 at 19:36
  • $\begingroup$ Use lower resolution particles on the hill in the background. $\endgroup$ – VRM Oct 10 '15 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.