0
$\begingroup$

I'm new in this community. My name is Francesco and I am passionate about Blender. I hope to learn well.

I have a problem I can not solve...

I wish animate the alpha channel and all the material properties (and textures) of an object and then render an animation in OpenGL. How should I do?

Thanks for your help.

$\endgroup$
2
$\begingroup$

Hover the mouse over a field on the materials tab (alpha channel on this example)

enter image description here

and press i to insert a key. Move a few frames ahead (arrow keys), change the value and press i again to insert a new key.

enter image description here

We now have a spline animating that field from one value to the other. It works just like normal animation.

enter image description here

A grey button means there are no keyframes. A yellow color means There is a keyframe on that frame, a green button means that the values have been animated, but there is not a keyframe on that specific frame.

An alternative to pressing the letter i is to right click on the value you want to animatate and select Insert Keyframe;

enter image description here

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ Being a tad bit pedantic here but while useful to some, one liners can be vague. We try to give answers that can help any beginner. An image or two in a context can help immensely (actually solving the problem with an example etc). $\endgroup$ – iKlsR Oct 8 '15 at 23:46
  • $\begingroup$ Thanks! Your answer is very simple and kind, but I already tried to do what you say. Into F-curve display I can see the change of the property value, but when I do the OpenGL rendering does not work. I give you an example: 1) I have a plane with a texture applied and I want this texture change the opacity value (in 50 frames) from 0 to 100 . Therefore I want the plane disappears in 50 frames (transparency from 100 to 0). Finally I want animate all sequence in 'OpengGL render animation' and save it in .avi. I hope to explain them well. Thank you. $\endgroup$ – Francesco Consoli Oct 9 '15 at 8:06
0
$\begingroup$

In order for transparency to show up in the open GL view, you must turn on the transparency option in the Object settings.

Objects will show as transparent in Solid and Material views, but not in Texture.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.