1
$\begingroup$

I was getting a perfectly blue and white cloudy colourful background but somehow it seems all darkened, I must've change some settings unintentionally, but I can't figure our how to put it back normal. can you please help me? here is a screen shot from my render

dark background

enter image description here

normal background which I want it back :) enter image description here

blender file I'm using cycles with pro skies add-on

$\endgroup$
  • $\begingroup$ Could you post your World Shader node setup? It may be something related with the Strenght, or the Environment map's colors, or a wrong socket connection. $\endgroup$ – Carlo Oct 8 '15 at 7:57
  • $\begingroup$ Are your clamp settings set to 0 in Render settings > Sampling? $\endgroup$ – gandalf3 Oct 8 '15 at 8:03
  • $\begingroup$ ok i 've added the blend file $\endgroup$ – ideorium Oct 8 '15 at 8:09
  • $\begingroup$ @gandalf3 yes, clamp direct was 0.03, i put it back to 0. but the reason I was using it was to avoid fire flies I wasn't aware of it'd be causing background go darker. is there anyway to avoid it get darker while clamp values non-zero? $\endgroup$ – ideorium Oct 8 '15 at 8:11
  • $\begingroup$ @ideorium It causes the render to go darker because it limits the maximum value a sample can return. If you set to to something greater than 1 (e.g. 1 or 2, depending on how much you can afford to let highlights to be clamped), it should still mitigate fireflies while still keeping the render normal looking. $\endgroup$ – gandalf3 Oct 8 '15 at 8:14
2
$\begingroup$

It looks like you might have set the clamp settings set too low. Try increasing them until you find a good balance between highlights and fireflies (I typically use something like 2, but you might be able to get away with 1).

You can probably leave Clamp Direct at 0, since direct bounces typically don't result in fireflies.

$\endgroup$
0
$\begingroup$

I came across this question searching for why my sky nodes were not working. With help from IRC we figured out the Use Environment checkbox in my render layers was unchecked:

Use Environment is unchecked

So my problem wasn't a dark texture, it was just blackness.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.