1
$\begingroup$

I am trying to understand why sometimes my Angle value is greyed out under Auto Smooth in the Data Panel of the Properties Editor. Does anyone have any idea why this happens, what it means and how to fix it so that it isn't greyed out anymore? For me this has nothing to do with Sculpting or being in Sculpt Mode. This happens randomly while performing regular poly modeling with booleans in Blender or when importing objects from other 3D packages.

$\endgroup$
  • 1
    $\begingroup$ Can you share a bit more? What is the context in which this is happening? $\endgroup$ – user1853 Oct 7 '15 at 18:00
  • $\begingroup$ This situation is an example of impossibility to set angle in Auto Smooth option. To "ungrey" it, open that scroll and delete data. Afaik, this is the most possible reason $\endgroup$ – Mr Zak Oct 7 '15 at 18:48
  • $\begingroup$ I can't figure out why it happens, hence the question. It feels like it happens randomly or like it happens when there may be some issue with the geometry but I haven't figured that out yet what that issue with the geometry might be. $\endgroup$ – Bryson Jack Oct 7 '15 at 20:38
  • $\begingroup$ I had the problem occur again and I selected the object and went to the Properties Editor>Data Panel>Geometry Data and clicked on Clear Custom Split Normals Data and that solved the issue. Do you want to enter that as an answer Mr. Zak? $\endgroup$ – Bryson Jack Oct 9 '15 at 21:45
  • $\begingroup$ I don't think so as it is already answered here. It's also explained there what could be the reason of this data to appear. $\endgroup$ – Mr Zak Oct 10 '15 at 18:37
14
$\begingroup$

Go to Properties editor > Object Data panel > Geometry Data and click on Clear Custom Split Normals Data to re-enable the angle setting.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.