I recently made a desk lamp model and set the samples to 1000 for an overnight render upon waking up the image was still rather grainy is this something in my blender that isnt set right or something in the scene itself?enter image description here

  • $\begingroup$ It's hard to comment on the scene when you don't attach/share the blend file. Did you enable multiple importance sampling for the lamp? $\endgroup$
    – dr. Sybren
    Oct 7, 2015 at 13:01
  • $\begingroup$ Im still very new to blender and i dont know how to enable multiple importance sampling you can download the blend file here. puu.sh/kBF0O/3f248d5a45.rar $\endgroup$
    – Rei
    Oct 7, 2015 at 13:15
  • $\begingroup$ multiple importance is a settings > surface option in the cycles material panel (not only for lamps) $\endgroup$
    – m.ardito
    Oct 7, 2015 at 13:50

1 Answer 1


I see a few things you can improve:

  • You can use much less polygons. The higher the polygon count, the longer the render will take. Try searching for tutorials that use subdivision ("subdiv") modifiers.
  • Use a cube instead of a collection of planes. There are gaps between the planes, which makes it harder for Blender to analyze the scene. Using a gapless cube will improve the rendering.
  • Reduce the number of light bounces; this is what I used in the render below: Light paths panel
  • Use GPU rendering if you have an NVidia or AMD video card: Rendering panel

  • Reduce the number of samples (because by now you don't need that many). I used 100 samples instead of 1000 in the render below.

This is the result (except the polygon count, I kept the lamp model the same), which was rendered in just under a minute on an NVidia Geforce GTX 970.

Render after applying the above points

  • $\begingroup$ Thanks very much how do i set my render to GPU? and how do i lower the polygons? $\endgroup$
    – Rei
    Oct 7, 2015 at 13:47
  • $\begingroup$ I've updated my answer to show some settings & panels. As for lower polygon count, a common approach is to model low-poly and then use subdivision surface modifiers to get smooth surfaces. Reducing polygons in a clean way is tricky, so it's best to start low. $\endgroup$
    – dr. Sybren
    Oct 8, 2015 at 7:44
  • $\begingroup$ I can't access the .blend to check, but I suggest one more point : - model at real scale $\endgroup$
    – Vinc3r
    Mar 3, 2017 at 12:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .