4
$\begingroup$

I've searched and toyed with this for quite some time. I have a penguin who's body is egg shaped and I'm trying to do the UV and texture for it. If I use projection from view then it comes out nearly OK except for a few areas (see image). The problem is that it seems no matter how I change the UV's vertices I can't fix the offending areas. I'm hoping someone can help. Thanks!

lower edge gets weird

Front view looks fine front view looks ok

$\endgroup$
  • $\begingroup$ How many subsurf levels have you set? Try to increase susurf level. $\endgroup$ – Paul Gonet Oct 5 '15 at 21:25
  • $\begingroup$ Thanks for the suggestion. I don't want to use subsurf because it is an asset for a game. $\endgroup$ – naphier Oct 6 '15 at 3:13
1
$\begingroup$

Try to reproject your texture upon a catmull-clark subdivided version of the mesh with the subdivide UVs option disabled.

This way you should be able to have more faces (and so a higher projecting accuracy), while maintaining the same UV islands.

Before:

enter image description here

After:

enter image description here

In my testfile this process was able to mitigate the effect of the distortion.

Once reprojected the texture, you can obiuvsly delete the modifier and keep your vertex count untouched.

$\endgroup$
  • $\begingroup$ thanks, but that's really not making much of a difference. That edge should continuously bow out. The white are is also mostly egg-shaped. I've tried up to 6 subdivisions. Any further and Blender is unusable.This is way harder to do than I expected :( $\endgroup$ – naphier Oct 7 '15 at 1:47
0
$\begingroup$

Make a higher subsurfed model and bake the normals onto the low-poly model. That should smooth out those distortions for you and keep your vertex budget level.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.