3
$\begingroup$

For one of my projects I have a propeller rigged with an armature. I have animated it to spin for the express purpose of getting motion blur on it (I am just rendering a still image). However when I turn on motion blur in the render settings (shutter = 1.00) the propeller is not blurred.

Here is a simplified example scene and render. Note the example box and cross are blurred properly but the propeller is crisp.

enter image description here

enter image description here

Thinking is was because the propeller is animated from an armature I tested a different armature-animated object but it blurs fine.

enter image description here

enter image description here

Why is the propeller not being blurred?

$\endgroup$

2 Answers 2

3
$\begingroup$

I can't be quite certain WHY, but Cycles isn't properly understanding the mesh distortion that your armature is doing. When I separated the moving parts of the rotor from the mast into two separate objects, and then animated the rotor object instead of the armature, the rotors blurred properly:

enter image description here

I suspect the armature isn't what's causing the problem, rather that it's the mesh distortion. Here's why: I also tried animating a shape-key instead of using the armature (with the whole mesh as one object), and Cycles did the same thing you're seeing. So, it must have something to do with Cycles not properly blurring meshes when they are deformed, instead of TRANSformed (LocRotScale). Even turning on "Deformation" in the motion blur settings for the mesh didn't change anything.

I suspect that you can still use the armature, so long as the moving components are a separate object from the non-moving components (or from components that move differently). I'd wager that your test rotor was also a separate object from the two cubes below it, and that's why it blurred properly.

This MIGHT be a bug. I'd recommend looking in the forums to see if it's been discovered. In the mean-time, it's somewhat more conventional to separate a mesh by moving parts, anyway ;-)

I hope that helps!

$\endgroup$
1
  • 2
    $\begingroup$ Thanks a ton! I'll accept your answer as soon as I can get to my other computer and test it. The strange thing is the second test I performed (3rd and 4th pics) works fine with blurring deformation. I suspect it is a bug, I'll try to get around to looking for it and reporting it over the weekend. $\endgroup$
    – PGmath
    Commented Oct 2, 2015 at 16:25
1
$\begingroup$

It seems that this problem was caused by having Auto Smooth enabled under the Object Data properties panel > Normals rollout. After disabling Auto Smooth and using an Edge Split modifier instead it renders as expected with motion blur.

I have no idea why enabling Auto Smooth interferes with motion blur, I suspect it is a bug.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .