8
$\begingroup$

So I recently made the switch to cycles rendering and smoke modifiers, but it's been giving me loads of problems already.

This is what the model looks like: model in viewport

And then when I go to render it, this is the result I get.

rendered result

Why is this happening?

$\endgroup$
6
$\begingroup$

It looks like you have a diffuse shader assigned to the surface of your domain. Make sure that there is nothing (or a pure white transparent shader) plugged into the surface socket on your domain object, and that the smoke nodes are plugged into the volume socket.

enter image description here

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Thank you for the help, PGmath. I'm trying to steer clear of nodes for now because they're just way over my head at the moment. I did find an alternate solution for it thanks to your diffuse advice. I went to the materials tab, added a new material, set surface as Transparent BSDF, and set it on pure white. This seems to have done the trick for me, and I thank you for the help on the subject. $\endgroup$ – Gh0stRunner Oct 1 '15 at 4:33
0
$\begingroup$

Problem AMD video cards do not support Smoke or fire rendering, instead of the fire or smoke you will get the domain rendered as a solid object.

Solution: Switch to CPU only on system preferences, or get an Nvidia video card.

Sadly there is no word on AMD support for Blender Fire and Smoke rendering.

| improve this answer | |
$\endgroup$
-1
$\begingroup$

VERY SIMPLE METHOD: Highlight the domain bounding box, then in the scene menu, top right, turn off the little camera icon and it will no longer appear in your render.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Not a solution. If you do that then you won't get smoke either. The smoke domain needs to be renderable. The materials need to be fixed in a way that only the volume is visible. $\endgroup$ – user1853 Jun 27 '19 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.