0
$\begingroup$

This question already has an answer here:

I'm trying to make a world background by enclosing the whole area in a big sphere, and projecting a spherical map onto that sphere, as per a tutorial on youtube that I can't post because it won't let me post more than 2 links, but it's called "Blender Game Tutorial (2.6): Building a 3D Game - Part 1".

The sphere looks normal in the 3d viewport. Here it is with 3d display mode set to Solid, and inset in that image is with 3d display mode set to Material, showing that my image successfully mapped onto the sphere to make a space background to the world.

User view, solid mode and inset material mode

But when I go into active camera view (numpad 0), part of the sphere disappears!

Active camera view

The same thing happens when I render with F12 (I can't post more than two images though).

It does not seem to be an issue clipping/camera distance. I varied the max camera distance to quite a wide range of values, and it didn't affect this phenomenon at all.

I'm fairly new at Blender, thanks for any help you can give.

$\endgroup$

marked as duplicate by Carlo, Mutant Bob, Community Sep 30 '15 at 15:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1
$\begingroup$

Try checking the N-panel (right pop-out of the 3D view) in the View section where the Clip settings are. This is not necessarily identical to the camera and controls what you see in the 3D view (which can be different from what gets rendered).

( your question is probably a duplicate of short view distance in 3d view? )

$\endgroup$
  • $\begingroup$ You are correct. I was definitely confusing the 3d view clip distance (the one in the N-panel) with the camera clip distance (in the camera properties). Increasing the camera clip distance fixed it. Thank you. $\endgroup$ – DrSandwich Sep 30 '15 at 15:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.