1
$\begingroup$

Before we get started - I'm a total newbie to Blender. So, take my terminology use with a grain of salt as I'm probably not using the correct words.

I'm trying to make a lantern. I built one in Blender, sent off a .obj file to a friend to "proof-read", and they sent it back to me (I believe they use 3DS MAX).

Now my lantern looks like this:

Lantern with missing faces

The shading is weird, but since this project is for 3D printing, I don't really care too much about that. However, I'm concerned that the apparently missing faces won't print properly.

I tried using the features to auto-create faces with the correct vertices selected, but nothing happened. So I thought maybe it was a display issue. But when I turned on face normal display, those two 'faces' are missing normals entirely, so I suspect that they're not there but the auto-create tool can't fill in the space for some reason.

Thoughts?

Edit:After repairing the lantern partially with lint, I'm getting a strange issue where the lint is repeatedly asking me to delete what seems to be working vertices. See the left side for several deleted vertices, and the right for an untouched side. The currently selected vertices are the ones it is describing as lint. enter image description here

$\endgroup$
  • $\begingroup$ Looks like flipped normals to me. Did you try pressing CTRL-N? $\endgroup$ – Johnson Martin Sep 28 '15 at 17:55
  • $\begingroup$ I did. I found a tutorial online that suggested that was the issue, and unless I did something wrong (entirely possible), it had no effect. I saw all the normals for the other faces flip as expected but not the ones for the missing faces. $\endgroup$ – JuniorIncanter Sep 28 '15 at 18:00
  • 1
    $\begingroup$ Ok, can you upload the file to PasteAll here?: pasteall.org/blend It would make it much faster for me to find the problem. $\endgroup$ – Johnson Martin Sep 28 '15 at 18:06
  • $\begingroup$ Maybe these are overlapping faces? $\endgroup$ – Faceb Faceb Sep 28 '15 at 18:10
  • $\begingroup$ I'll post the blend when I get back to my desktop. Thanks for the help. $\endgroup$ – JuniorIncanter Sep 28 '15 at 20:46
2
$\begingroup$

In this case, you have a simple problem of missing faces. One way to verify this is to install the MeshLint addon for Blender. Then use the "Check Non-manifold Elements" tool. This will find any holes in your mesh.

To fix the holes, select the edges around one hole and press F. And repeat for any remaining holes.

enter image description here

Other common mesh problems can be fixed by removing vertices that share the same space. Called doubles. To do so, press W and select Remove Doubles.


$\endgroup$
  • 1
    $\begingroup$ Also, Ctrl-A will allow you to apple the transform of the object. Like if you scaled a cube to 2x it's size on one axis while in object mode, it could cause problems when doing things like beveling in edit mode or adding a modifier. Pressing Ctrl-A will solve that issue. $\endgroup$ – Johnson Martin Oct 1 '15 at 13:03
  • $\begingroup$ Thanks for introducing us to MeshLint! I had been using Select Non-Manifold and Select Similar, but this should be even faster. $\endgroup$ – Mentalist Oct 2 '15 at 9:08
  • $\begingroup$ @Mentalist No problem. I've been using MeshLint for years now. It's a great modeling add-on. Another add-on to look at is the F2 add-on, it's incredibly useful for modeling: wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Modeling/… $\endgroup$ – Johnson Martin Oct 2 '15 at 18:59
  • $\begingroup$ Okay, so this allowed me to finally close the four missing faces. However, I still have 8x nonmanifold elements. How do I check where these are? $\endgroup$ – JuniorIncanter Oct 6 '15 at 2:30
  • $\begingroup$ So I figured out that I just keep the "check nonmanifold elements" checkbox check and press select lint. Works so far, and cleaned up most of them. $\endgroup$ – JuniorIncanter Oct 6 '15 at 2:39
-2
$\begingroup$

enter image description here

Add an edge split modifier to address your shading in general. This will allow sharp corner where necessary. Consider removing doubles.

$\endgroup$
  • $\begingroup$ I'm still new to Blender. What do you mean by doubles, and how do I remove them? $\endgroup$ – JuniorIncanter Sep 30 '15 at 14:34
  • $\begingroup$ Also, does the shading matter when doing 3D printing? $\endgroup$ – JuniorIncanter Sep 30 '15 at 14:34
  • $\begingroup$ @JuniorIncanter No, it does not. A 3d printer does not use the surface normals when printing. Therefore the direction of the normals is irrelevant. $\endgroup$ – Johnson Martin Oct 1 '15 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.