1
$\begingroup$

To get rid of fireflies in blender cycles, under the sampling do I change the indirect clamp to .98 or the direct clamp to .98 or both?

$\endgroup$
1
  • 1
    $\begingroup$ Clamp indirect. 0.98 might be too much clamping on the highlights. Tray a value like 3.0 $\endgroup$
    – user1853
    Sep 27, 2015 at 0:57

2 Answers 2

1
$\begingroup$

First clamp cut the light value to the maximum you put so try first using hight values and then lowering from that as if you put it too low it will remove some light that is "real".

Second, you want to cut first the indirect light as it's normally what make more fireflies and direct light value is higher.

I recommend to start using a value of 100 or 10 in "clamp indirect", and reducing from it.

$\endgroup$
-1
$\begingroup$

I always use a value of 9.0. Be careful with that. If you increase that value a lot your scene will lose brightness. If it continues rendering many fireflies I would try other tips:

  • Increasing the number of samples
  • Reducing the specular color below or equal to RGB(0.8, 0.8, 0.8)
  • Using bilateral blur node on compositing
$\endgroup$
3
  • $\begingroup$ I think when you said "If you increase that value a lot..." you really mean decrease as with higher clamp value you allow more light. $\endgroup$
    – PhoneixS
    Sep 28, 2015 at 14:49
  • $\begingroup$ That is said on the blender wiki page. If you increase clamp values you can lose brightness in your colors (blender.org/manual/render/cycles/settings/…). So you can remove pixels which contribute to that bright colors. $\endgroup$ Sep 28, 2015 at 15:42
  • $\begingroup$ From the wiki " However note that as you clamp out such values, bright colors in other places where there is no noise will be lost as well." It said when you clamp it, that is when you lower the number $\endgroup$
    – PhoneixS
    Sep 28, 2015 at 17:09

You must log in to answer this question.