2
$\begingroup$

This question already has an answer here:

Yesterday Blender was working fine. Today it isn't recording any history, I can't undo anything. Also, when I add a new mesh, all the options in the Operator section of the Tool Shelf are grayed out, I can't do anything with them.

I checked User Preferences, it shows 32 steps in the Undo section of the Editing tab. I tried undoing by the Ctrl+Z shortcut, pressing the "Undo" button in the Tool Shelf, and clicking on the "Undo history" button, which does nothing. I tried closing Blender and opening it again. Rebooting does nothing. It was working fine yesterday. I have 2.76 running on Ubuntu 14.04 64-bit.

I need to go ask elsewhere how to check the most recent changes to my system - the system's software updater downloaded 40-odd MB of stuff this morning, but I don't know what it was.

Should this be reported as a bug? Should I uninstall and reinstall Blender? When I open it, the mini-splash screen has a date and time in the top right corner - I'm guessing that indicates the last time the program was changed by an update. That date is a week ago, so that isn't it. Does that definitively mean the problem is with my OS?

$\endgroup$

marked as duplicate by Ray Mairlot, Mike Metcalf, gandalf3 Sep 24 '15 at 20:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    $\begingroup$ Does this help? blender.stackexchange.com/questions/8262/… $\endgroup$ – Ray Mairlot Sep 24 '15 at 15:19
  • $\begingroup$ @RayMairlot yes, that got me everything back! Yay! But I'm pretty sure it was never checked, so why would it be making a difference now? And surely it doesn't have to be checked for basic functions to work. $\endgroup$ – kim holder Sep 24 '15 at 15:26
  • $\begingroup$ @RayMairlot Based on the linked question, this has to do with some add-on I recently used. I opened the file i was working on last night, and there is nothing there that involved an add-on, other than Extra Objects, and that was there most of yesterday and caused no issue. Maybe i should edit that into the question. $\endgroup$ – kim holder Sep 24 '15 at 15:35
  • $\begingroup$ I think it must have been checked and somehow got un-checked when you returned to the file. If it hadn't been turned on you would have had the problems in your question right from the start. As to what might have caused this, I don't know. $\endgroup$ – Ray Mairlot Sep 24 '15 at 15:46
  • $\begingroup$ @RayMairlot So Global Undo is checked by default? It's a case where you can uncheck it if you have a situation where you need all the memory you can get? I have an intermittent mouse lag problem, i could certainly have unchecked it unintentionally without noticing, i was in that section a couple of times yesterday. $\endgroup$ – kim holder Sep 24 '15 at 15:51

Browse other questions tagged or ask your own question.