3
$\begingroup$

I have an .obj model from a game, and its .dds texture map. I simply want to make some adjustments to the texture. Normally I can do this just using Photoshop, but this particular texture map is really confusing and I can't figure out which part of the body I'm painting. How can I view the textured model while editing the textures?

Edit: Still trying to figure this out... these are the steps I followed:

  1. I imported the .obj file
  2. I opened the .dds file in UV/Image Editor
  3. I selected the model, switched to Edit Mode, then did Mesh > UV Unwrap > Unwrap
  4. In UV/Image Editor, I did UVs > Unwrap

Now I have this:

enter image description here http://puu.sh/kt7PA/79f4596875.jpg

This isn't right, is it? Besides the fact that it doesn't look like it's mapped right at all, I tried painting on it and couldn't see any difference on the model.

$\endgroup$
  • $\begingroup$ Texture Painting ...... blender.stackexchange.com/questions/38399/… $\endgroup$ – atomicbezierslinger Sep 24 '15 at 6:28
  • $\begingroup$ If the model has had texture already then it's likely it has been already unwrapped. At the same time, according to your 3 and 4 steps, you replaced original unwrap (which you'd like to use to simply adjust texture) with the new one (which you see after step 4). $\endgroup$ – Mr Zak Sep 30 '15 at 11:53
  • $\begingroup$ Has this question been answered? If so, please except an answer. If not, please clarify what problems you are still experiencing. $\endgroup$ – Uncle Snail Jan 20 '16 at 1:20
1
$\begingroup$

Sometimes while importing an obj model, the uvs get messed up, which eliminates all simple answers. If not, there is an easy way.

  1. import the model into Blender.
  2. Switch from object mode, to texture paint mode.
  3. Switch to textured view. (or material view, depending on how you like it and your circumstances.)

The most common error, besides the UVs being messed up, is the material not working in Blender. If you are simply texture painting, this is easy to fix. Simply,

  1. Add a material. (or click use nodes on the current one).
  2. Load the texture into the material.

Now it should show up.

This same concept applies to most model types. Here is an illustration using a .3ds model I got from www.archibase.net. In this example, the uv map was already there how it was meant to be, I just needed to adjust the material. If I would have re-unwrapped, that would have ruined the intended position of the texture. enter image description here

$\endgroup$
0
$\begingroup$

Open up the texture map in the image editor, and unwrap the uv of the model. If you also have the 3d view open, you should be able to see the texture getting edited as you edit it.

$\endgroup$
  • $\begingroup$ Please add more info to this answer. $\endgroup$ – David Sep 25 '15 at 19:44
0
$\begingroup$

For one thing, you need to reimport the game model so that it has its original UVs. When you use the Unwrap operator, it replaces the UVs of all the faces that you've selected with low-distortion, unique UVs. This is probably not what you want to do if you're just modding the texture.

Once you've got the model reimported into Blender, the next step is to make sure that you're using Blender Render. In the top bar of the program there's a dropdown that might say "Blender Render", "Cycles Render", or "Blender Game Engine." If it's not on Blender Render, click on it and change it to Blender Render.

You'll need to set the viewmode of your 3d viewport to Textured. This can be done with the hotkey Alt+Z by default, or there's a dropdown menu with all the view modes in the bottom bar.

The next step after all of this is done is to split the 3d View so that you have a 3d View and a UV/Image Editor. Open up the texture in the UV/Image Editor and enter Edit Mode in the 3d View. Select all of the faces on the model with the A key, then if the UV/Image Editor switched to a blank image go back to the UV/Image Editor and switch back to the texture you wanted. This sets the active texture for all of the polygons on your mesh to be the one you wanted to edit. Now you can exit Edit Mode. You may want to open the N Panel in the 3d View, go down to the Shading section, and set shading to Multitexture and turn Shadeless on. If you decide that you want some lighting on the model so it's easier to see the shapes, I recommend using a Hemi lamp as that will show you the models shape while lighting it entirely.

You can change the UV/Image Editor from View mode to Paint mode in the bottom bar and use the T panel to pick colors. This way you can paint on the image in Blender. If you decide that you need to go back to Photoshop to do your painting, you can easily preview what it's going to look like on the model by saving the PSD, loading it into Blender, setting it as the active texture, and resaving the PSD from Photoshop whenever you need to view the changes, going back to Blender and using the hotkey Alt+R to reload.

$\endgroup$
  • $\begingroup$ Spencer, thank you so very much for this amazing answer!! I really appreciate all the detail you've included! Just one problem now... I can sometimes get paint to show up on the model, but not always? I've found I need to have X & Y tiling turned on, and then I have to scribble quite a bit to get it to show anything. But even then, it doesn't always seem to work. puu.sh/kwlbj/fa1a83947d.jpg $\endgroup$ – Zuzu Oct 2 '15 at 22:39
  • $\begingroup$ May I see the UV layout, please? Have you tried following a similar procedure with a cube that's got a simple UV layout (say, done by adding a cube, going into edit mode, unwrapping with the hotkey U and then choosing Smart UV Project) to see if you can get your painting to show up on a more straightforward mesh? $\endgroup$ – Spencer Brown Oct 4 '15 at 17:04
0
$\begingroup$

Don't listen to the people telling you to unwrap the model. If you want the uv's of the model that it currently uses with the texture youre trying to modify then all you need to do is select all faces and look in the uv image editor. The uv's should be there. If you unwrap then it gets rid of the uv the model already uses which means you need to re texture or adjust the new uv's to fit the texture.

To do what i think you want, don't unwrap, just apply a new material. Go to cycles. Make sure your object is selected and go to node editor add and "image texture" then import and select the texture you want to modify or select it if its already in. Then connect the little yellow do to the diffuse nodes yellow dot. If you look in the uv image editor with all faces selected you should see your uv's of the model. At the bottom select the image you used in the "image texture" node earlier. Now texture paint the 3d model or in uv image editor select paint and paint.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.