0
$\begingroup$

I'm using a Noise Texture (shader) with the Normal influence channel (in BI). And it doesn't show in render. Something does show when I check the Color influence, but not Normal influence. I think I tested every possible setting, with no success. See the attached images for my settings and the render result. The blue tip should show some bump. What am I doing wrong? Maybe it has to do with scale. The tip is just a few millimetres thick, but I also tested different scale values and nothing shows. The noise does show in the preview though.

I'm attaching another image showing the vertices.

Rendered tipMaterial settingsTexture settingsRender Layers settingsVertices

$\endgroup$
  • $\begingroup$ Can you show the vertices which have the material applied in edit mode? $\endgroup$ – atomicbezierslinger Sep 23 '15 at 17:46
  • $\begingroup$ Please try 3 tests changing the Influence/Bump Mapping/space ... Object/Texture/View. I have seen some differences for small pixel bounds. There are some warning against using this noise for animation. Clouds are suggested in some documentation. $\endgroup$ – atomicbezierslinger Sep 23 '15 at 19:14
1
$\begingroup$

You will get different results with the Influence/Bump Mapping/Space setting

enter image description here

$\endgroup$
0
$\begingroup$

Success! After testing all three of the spaces as mentioned by AtomicBezierSlinger I accidentally discovered what the problem is:

None of the texture shaders (with Normal influence) work with Mesh Lights. It's another limitation of BI obviously. A regular Lamp is needed.

Solved.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.