5
$\begingroup$

tracking scene in blender

I started with my iPhone 4 footage and managed to get a solid 0.7159 solve error (using the phone preset w/k1+k2+focal length) with just 21 markers (including my new Favorite Thing, perspective markers). Huzzah!

Except when I Setup Tracking Scene - the presented solution shows the camera and the markers in an almost completely straight line, or has the camera stretched out to a ridiculous distance, covering the markers (which are in an almost completely straight line).

I've set the floor, the origin, the x axis, the scale - all to only minor adjustments.

How can I convince Blender that it's looking at a fairly broad street, not a tiny, thin path?

$\endgroup$
  • $\begingroup$ After poking about and resetting my iPhone preset multiple times, the problem seems to have fixed itself. It seems unlikely it's just the iPhone preset that solved the issue (though you can see I was having problems with the camera focal length), but after trying the same actions multiple times and hoping for a different outcome, it appears to have solved itself. If anybody has an idea what happened, post away - otherwise I'll delete this question soon. --Rev $\endgroup$ – Reverend Speed Sep 22 '15 at 23:16
3
$\begingroup$

The problem is displayed in your screenshot.

camera and tracking settings

First off the iPhone 4 has a 3.85mm focal length (part of the iPhone 4 preset), no were near 457.

Because you had a focal length that was way off, it messed up blender big time. No doubt you had Refine in the Solve settings set to adjust the K1 and K2 values. -1237926.25 is a HUGE number, way bigger then anything you will ever really need; for that matter the K1 value is way too high. The focal length and Lens Distortion values are the cause of your problem.

$\endgroup$
  • $\begingroup$ It's a fair observation, but I've no idea how the focal length got set to that as I've only ever selected the iPhone 4 preset. On subsequent tries, using the preset & deleting the constraint & resetting the Blender camera focal length, I've BOTH had the same result (markers laid out in a very thin line) and a very reasonable scene setup. Baffling. Trying again, but barring immediate success will mark your answer correct and delete this question. $\endgroup$ – Reverend Speed Sep 23 '15 at 8:54
  • 1
    $\begingroup$ @ReverendSpeed no need to delete your question. Future blender users may find help here when they have a similar problem. $\endgroup$ – David Sep 23 '15 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.