2
$\begingroup$

I have a little problem-whenever I want to select a bone in pose mode, I select an object behind it instead. If I want to select the bone, I have to select it in edit mode and then switch to pose mode and that is realy slow and anoying. how can I fix this?

$\endgroup$
1
  • $\begingroup$ Try turning off the X-Ray toggle $\endgroup$ May 8, 2020 at 14:06

4 Answers 4

1
$\begingroup$

That's likely because there are many overlapping objects. A way to work around this is to press and hold Alt and RMB, and while still holding the mouse button, move the cursor so it is over the name of the object you want to select and then release.

This, basically gives you a list of all the objects "under" the mouse, disregarding the view Z distance, so you can pick the one you want.

$\endgroup$
2
$\begingroup$

Make sure the bone you are trying to select is selectable.

In the below EYE_CTL cannot be selected:

enter image description here

$\endgroup$
1
$\begingroup$

In the Viewport Display of your armature, if you've selected the In Front option, you can't select bones in pose mode, so, unselect it.

$\endgroup$
2
  • $\begingroup$ This does fix it for me, but the weird thing is I've had In Front turned on from the start and was able to select other bones without having to select them in Edit mode first. I'm not sure what changed that prevents freely selecting bones in Pose Mode now. $\endgroup$ May 14, 2020 at 4:15
  • $\begingroup$ Having the same issue, and haven't figure it out. Have to select the bone on edit mode then change to pose mode. Very annoying. Is there a lock bone pose selection key shortcode or something? $\endgroup$
    – raphie
    Feb 2, 2021 at 17:58
0
$\begingroup$

If I am trying to select things, and it doesn't work, just selects other stuff, I his Z, which makes it wire-frame, and I can usually select with ease! I hope this helps!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .