2
$\begingroup$

Once I set up the lighting I've noticed that there is a very Hard Shadow falling from one object to another, from the Sky Map. Is there a way to make the Shadows softer without affecting the Intensity of the Sky Map.

enter image description here

| world settings

enter image description here

I put the samples up to 200, the difference isn't that big in this scene, I don't like this Harsh Shadow, and want to change it, but no method comes to my head

enter image description here

I tried unchecking the Shadow box in settings of the front object; the one casting this harsh shadow, and it seems to work, but now I am not sure if this is a good way of getting around it?

enter image description here

$\endgroup$
  • 2
    $\begingroup$ What would that first image look like with more samples? It's hard to tell how hard the light is in the first place. $\endgroup$ – TARDIS Maker Sep 21 '15 at 21:55
  • $\begingroup$ @TARDIS Maker as you can see setting the samples upto a higher value, didnt really change a lot in my instance, but thanks for responing anyway $\endgroup$ – Igor Tatarnikov Sep 22 '15 at 11:29
  • $\begingroup$ I see a few options: 1- Add a very big ara light behind the camera to control the shadow level. 2.-Make a shadow pass to control the darkness of the shadows. Use less Ambien Occlusion. Also take a look at this answer, it might give you some ideas: blender.stackexchange.com/questions/8930/… $\endgroup$ – cegaton Sep 22 '15 at 12:16
  • $\begingroup$ I guess that is coming from your particular scene setup (I mean the position of each object). Usually you have the opposite problem when you are using a background texture for lighting a scene. Could you post more screenshot about where the light comes from and where the objects are? Do you have the same issue in other scenes too? Or just in this one? $\endgroup$ – Carlo Sep 22 '15 at 12:41
  • $\begingroup$ You know I never really remember myself to have issues like that before, I am thinking now maybe this could be caused by the Film setting in the Color managment Properties. I will post where the light is coming from etc. $\endgroup$ – Igor Tatarnikov Sep 22 '15 at 13:48
6
$\begingroup$

Depending on what you want, there are a couple ways to approach this.

Increasing the Size (in Properties > Lamp) of the main lamp to produce softer shadows:

enter image description here

Or Angle value if you are using blender 2.8 :

enter image description here

Here's a gif showing the size animated from 0.1 to 1:

enter image description here

Adding a second lamp to to put more light into the shadowed area:

enter image description here

enter image description here

Disabling Shadow rays for an object allows light to pass through and illuminate surfaces behind it. If this works for you, then all well and good, but be aware that this isn't a physically accurate phenomenon and may look strange in some situations.

$\endgroup$
  • $\begingroup$ And how would one increase the "size of the light" for an Emission Material? $\endgroup$ – Edward Nov 1 '18 at 12:01
  • $\begingroup$ @Edward Increase the size of the object the material is applied to $\endgroup$ – gandalf3 Nov 1 '18 at 22:12
  • $\begingroup$ But then either the lampshade object is very large compared to the rest of the scene, or the bulb goes outside of the lampshade. $\endgroup$ – Edward Nov 1 '18 at 22:53
  • $\begingroup$ @Edward The relationship between shadow "softness" and light source size is an artifact of light traveling in straight lines. If you aren't happy with the results, then you can either tweak your lighting, materials, and scene to "spread" light around (e.g. large bright diffuse surfaces can effectively bounce light from a small light source, in a sense becoming a large light source itself) or break from following physical rules and use whatever means necessary to get the look you want (this route may be difficult in a physically-based engine like cycles) $\endgroup$ – gandalf3 Nov 2 '18 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.