0
$\begingroup$

I got a Minecraft rig which I want to have as a transparent image for a thumbnail. I always get these weird lines around the head (and sometimes on the rest of the rig as well), but I want to get rid of them as they don't look nice. I tried removing the lines in Photoshop, but that takes a lot of time.

Please have a look at the screenshot which has been attached to this post. How do I get rid of the lines around my Blender Minecraft rig? I'm a Blender beginner, so please send very clear and detailed instructions if you know the answer! :)

Thanks!

Problem occurs with: - Windows 7 Pro 32-bits - Windows 10 Pro 64-bits - Blender 2.75a (also had the problem in previous versions)

Download link for .blend file: https://mega.nz/#!LV4zAJ6a!SYgFytB9C92YXd5gNaH8C7m2fWys2e0AetcRpmFeTwc

The white and colored lines around the head of the Minecraft rig are what I want to get rid of.

$\endgroup$
5
  • $\begingroup$ Is it possible to see the .blend file?! I assume that your edges are not correctly align/ that you have doubles (doubled vertices laying on top of each other) $\endgroup$
    – DoubleVoid
    Commented Sep 18, 2015 at 15:39
  • $\begingroup$ Hey, I just added a download link for the .blend file to the post :) $\endgroup$
    – MrHat
    Commented Sep 18, 2015 at 16:34
  • $\begingroup$ Please pack your textures! Textures are not saved with the blend file unless you pack them. Use File->External_Data->Pack_all_into_.blend and re-upload your file $\endgroup$
    – user1853
    Commented Sep 18, 2015 at 16:36
  • $\begingroup$ Thanks, I changed the URL so now it should be saved correctly and you can download it :) $\endgroup$
    – MrHat
    Commented Sep 18, 2015 at 16:48
  • $\begingroup$ I get an error when I try to download your .blend file. Please upload it here: blend-exchange.giantcowfilms.com $\endgroup$
    – DoubleVoid
    Commented Sep 18, 2015 at 20:47

1 Answer 1

4
$\begingroup$

It appears to be a UV layout problem - not enough margin between the UV islands, so color data is bleeding over. From what I can see of the UV texture on the right everything is just packed way to closely together. But maybe you can fix this by scaling the UV islands in a little, one-by-one.

Instead of this...

A UV layout with no margin between the islands

More like this:

A UV layout with some margin between the islands

Also, to fix triangles like that one on the arm, enable Auto Smooth in the Mesh Context.

Enabling Auto Smooth

Update:

I looked at your .blend and it does appear that the UV layout is the problem.

Note how there is no margin between the islands.

Minecraft character UV layout

In addition to that, there are parts of the layout that are doubled-up. This may or may not be intentional, but it means a texture in that region will show up on more than one place on the mesh.

$\endgroup$
3
  • $\begingroup$ could also be an issue with non premultiplied textures... without the file is hard to guess. $\endgroup$
    – user1853
    Commented Sep 18, 2015 at 16:18
  • $\begingroup$ Hey, I just added a download link for the .blend file to the post :) $\endgroup$
    – MrHat
    Commented Sep 18, 2015 at 16:34
  • $\begingroup$ If you can fix the problem (and if you want to), can you send me the .blend file? :) $\endgroup$
    – MrHat
    Commented Sep 18, 2015 at 16:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .