4
$\begingroup$

Sometimes I would like to solidify only certain parts of a mesh. I know I can use the solidify under the faces (Ctrl+F) menu, but often I would like to do it in a non-destructive manner using the solidify modifier.

The solidify modifier does have an option to solidify only a particular vertex group. However when I use this option it solidifies (i.e. duplicates) the entire mesh, but only moves out the vertices which are in the vertex group leaving the areas not in the vertex group with double overlapping geometry. This results in a giant hideous z-fighting mess, as shown below.

enter image description here

So can I have the solidify modifier apply only to the vertex group and not create this mess?

$\endgroup$
  • 1
    $\begingroup$ Is the goal similar to dynamic paint or displacement by texture? $\endgroup$ – atomicbezierslinger Sep 15 '15 at 21:37
  • $\begingroup$ Try enabling Only Rim in the modifier $\endgroup$ – Denis Sep 15 '15 at 21:42
  • $\begingroup$ Add a Weld modifier after Solidify modifier. $\endgroup$ – DNCGame Apr 18 at 8:59
2
$\begingroup$

There are really two ways of handling this issue.

1) As Denis suggested in the comments, check Only Rim. This won't give you thickness, but will just displace the faces in the vertex group.

2) Offset the Factor a small amount:

factor settings

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.