0
$\begingroup$

I'm going to try and use the BGE to do a simple arch-viz. But before I commit to that I need to make sure I've got the ability to publish an EXE for the presenter who will be showing it to the client.

I created a simple BGE scene that simply spins the camera around a cube when the user hits a key. It works just fine in Blender.

I then published it to EXE using the Save As Game Engine Runtime (v0.3.1) per the Blender Wiki instructions. The EXE is created, the dlls are all copied over. But running the EXE gets me a brief console pop up and then immediate crash.

I've tried with both official 2.75 and the 2.76 test build with the same results.

I'm on Windows 7 Professional.

Blend file is here: Dropbox

Thanks for any and all assistance.

$\endgroup$
  • $\begingroup$ You can try to reinstall a fresh version of Python. $\endgroup$ – Hack0re Sep 15 '15 at 18:55
  • $\begingroup$ Works fine for me on linux. Have you tried the newer game engine publishing addon? $\endgroup$ – gandalf3 Sep 15 '15 at 19:43
  • $\begingroup$ I believe the problem I'm experiencing has to do with the version of Python I have loaded on this machine. I have version 3.4.3 and Blender seems to be running 3.4.2. I'm going to try taking 3.4.3 off the computer and installing Python 3.4.2 and see if that fixes things. $\endgroup$ – D. Waschow Sep 28 '15 at 13:33
1
$\begingroup$

Go to where you installed blender, and copy all the files except blender, blenderplayer, and uninstall to the folder where you .exe is. This should fix your issue.

$\endgroup$
  • $\begingroup$ I believe this fix is for 64 bit. $\endgroup$ – Billy S Jul 16 '16 at 22:21
  • $\begingroup$ Also, if you OS is Linux, than the problem is most likely a different one. $\endgroup$ – Billy S Jul 16 '16 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.