0
$\begingroup$

In my node editor I have a small movie clip with a green screen. I keyframed it to get rid of the green screen and I am using a transparent background image. I have realized that most of the video formats don't support transparent backgrounds, so I am trying to just render it frame by frame. However, when I use a format that should support transparency, like png, the pictures just come out with a brown or black background. My goal is to overdrop the clip on another video I have. How do I export this clip with a transparent background? Thanks for any help!

$\endgroup$
0
$\begingroup$

Nevermind, figured it out. Turns out I was rendering with the RGB preset instead of RGBA.

EDIT: Expanding upon my explanation: I was getting a brown background whenever I didn't check "use alpha" on my output node. So I checked that and it solved that problem. I was getting a black background on my render images because of my answer stated above. On your render options in the properties tab, right next to the type of file output you have 3 options: BW, RGB, RGBA. I was rendering my images with the RGB preset, which stands for Red Green Blue, instead of RGBA which stands for Red Green Blue Alpha. So it makes sense that it previously wasn't rendering my alpha background.

$\endgroup$
  • 2
    $\begingroup$ please expand on your answer a bit, to make it more useful to future viewers. $\endgroup$ – David Sep 14 '15 at 1:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.