2
$\begingroup$

I tried all answers from Internet, press W - "Clear All Restrict Render", uncheck my post processing - "Compositing", recalculate my UV, Ctrl+N, switching back to CPU render, switch to blender render, etc., none of them works in this case. NOt sure if this is because I import the object from makehuman. My object view, material view and render view attached.

Material view:

enter image description here

Object view:

enter image description here

Who knows any other trick I should try?

Render result

$\endgroup$
  • 2
    $\begingroup$ Can you post your file? $\endgroup$ – cegaton Sep 13 '15 at 18:10
  • $\begingroup$ Please do the following. Show the layer of the dark ribbed body. Show the render layer settings. Someone may move picture of links to the main question. $\endgroup$ – atomicbezierslinger Sep 13 '15 at 18:11
1
$\begingroup$

From your screenshots, I see that the only light source that is present in the scene is the default point lamp..

It looks like this is not enough to light up your robot. Maybe try changing that to a sun lap, or boost the power of the overall lighting in the World settings.

$\endgroup$
  • 2
    $\begingroup$ Given the appearance of the render he posted, it is not very likely the issue has to do with insufficient lighting. $\endgroup$ – Mike Metcalf Sep 14 '15 at 16:31
  • 1
    $\begingroup$ @MikeMetcalf Why not? To me it looks like the render is missing a light source. And there aren't any visible in the scene. $\endgroup$ – PGmath Sep 14 '15 at 19:49
  • $\begingroup$ @PGMath You are likely correct in saying that the scene needs another light source. What I'm thinking though, is that even without another light source the missing exoskeleton would still be visible as a black silhouette in his render. The inner suit is visible in the render, but the exoskeleton is not visible at all. If this was a missing light issue, I would expect the entire scene to be pitch black. $\endgroup$ – Mike Metcalf Sep 14 '15 at 20:06
  • $\begingroup$ I agree with what atomicbezierslinger has implied... this could probably be a problem with render layers. Seeing the scene and render layers may shed some light on this. $\endgroup$ – Mike Metcalf Sep 14 '15 at 20:08
  • $\begingroup$ @MikeMetcalf Good point, I did not notice the exoskeleton. Though it doesn't look like render layers are at fault as he does not have objects on any other layers (look at the bottom of the first two screenshots). $\endgroup$ – PGmath Sep 14 '15 at 20:47
1
$\begingroup$

I know this is old but in case someone else has a similar issue, this might help. I just ran into this issue my self. My particular instance, in Object View>Duplication, setting was set to Group. Set it to None and my object renders now. I basically had it set to an empty group.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.