I am using latest version of Blender (2.75a) and I'm having a problem with animation.

I have one animation in the Dope Sheet and it's working as it should, but I am unable to make another one on the same model. I did save it in the Action Editor, but when I return to Dope Sheet and delete all of keyframes, then insert new ones, the first animation doesn't work. I also tried with Blender (2.71) and it didn't worked, but I did the same thing with another model a few months back in 2.71 and it worked just fine

If anyone knows how to fix it I would be really grateful.


I removed ALL empties and IK's I had in my mesh and I enabled Auto-IK and Auto Keyframing

I made an Action1 in Action Editor and went back to Dope Sheet where I placed my keyframes for the first action.When I was done with that I went to Action Editor and created Action2 and again went back to Dope Sheet where I placed keyframes for second animation

Everything works as it should and no problems whatsoever

  • $\begingroup$ Welcome to Blender.SE! It sounds like you want to have multiple animations on one object (that blend together?). Have you looked into using the NLA editor at all? $\endgroup$
    – CharlesL
    Sep 13, 2015 at 11:46
  • 1
    $\begingroup$ Feel free to answer your own question with how you solved it, that'll take it off the unanswered list. $\endgroup$
    – PGmath
    Nov 24, 2015 at 16:35

1 Answer 1


To add a Second animation you have to change first to Action Editor at the bottom from Dope Sheet

enter image description here

and then press the New button at the bottom:

enter image description here

And now you can Animate and switching between your animations

EDIT: After you created an Animatin you should press the "x" Button next to it and then press new:

enter image description here

and then press the new button:

enter image description here

It should work

  • $\begingroup$ As I said,I did that but it doesn't work for some reason $\endgroup$
    – ii7scw
    Sep 13, 2015 at 12:24
  • $\begingroup$ You said that you have been deleting some keyframes, but that is in no need $\endgroup$
    – A.D.
    Sep 13, 2015 at 14:01
  • $\begingroup$ I did that what you suggested so I have Walking Action,it's working great so I make another Action called Attacking and return to Dope Sheet but there are still keyframes from Walking one so I need to delete them but when I do that Walking Action is no longer working I have to go now but I'll post screenshots later today to help you realise my problem $\endgroup$
    – ii7scw
    Sep 14, 2015 at 11:04
  • $\begingroup$ See my answer and try it again, also try restarting your Blender. If that doesn help, could you upload your blend file $\endgroup$
    – A.D.
    Sep 14, 2015 at 11:33
  • $\begingroup$ Didn't worked,could I add you on Skype to give share my .blend file $\endgroup$
    – ii7scw
    Sep 14, 2015 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.