5
$\begingroup$

How do you texture paint on a sphere? I want to paint without it repeating... But I get sharp shards of the color I'm painting with all over the object when I'm not even painting there.

enter image description here

$\endgroup$
  • $\begingroup$ Whoa, you should probably recalculate normals on that sphere. Or better yet, do Add Mesh > Round Cube > Sphere. This will give you a sphere with topology that is much more texture-friendly. To do this you'll need to enable the Extra Objects mesh add-on in your preferences. You can then UV unwrap using Follow Active Quads and get a clean unwrap, then scale the UV map to fit within the texture area. $\endgroup$ – Mentalist Sep 12 '15 at 1:01
3
$\begingroup$

Vertices in edit mode to show uv unwrap. Any non overlapping uv will do.

enter image description here

Sphere in paint mode, stencil used.

Two brushes used. Gold Brush Showing.

Material and Texture Showing.

enter image description here

$\endgroup$
6
$\begingroup$

I believe your problem in the screen shot you posted is because the direction of your normals don't match. Or it could be that you accidentally made two identical spheres overlapping. Without seeing your .blend I can't verify the nature of the problem. But there is a better way to texture a sphere anyway, and I will now share that with you.

1. Use a round cube instead

To get these menu options enable the Extra Objects mesh add-on in your preferences.

Adding a round cube

2. Set round cube's divisions as desired

Setting round cube's divisions

3. UV Unwrap using Follow Active Quads

UV unwrapping using Follow Active Quads

4. Scale to fit your UV layout and add an image texture

UV unwrap result, scaled down

Rotate 180° if feeling unholy ;-)

(I'm just having a little fun, so I hope you guys won't get cross with me)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.