3
$\begingroup$

I am trying to figure out how to work with render layers. Now I have two render layers connected to the output via Alpha Over node. But when I render the composite output layer is not the combined output of the two separate render layers. What is my stupidity?

enter image description here

$\endgroup$
  • $\begingroup$ related: blender.stackexchange.com/questions/7573/…, more explanation: blender.stackexchange.com/a/3003/3710 $\endgroup$ – p2or Sep 10 '15 at 11:43
  • $\begingroup$ Cycles or internal? The question is tagged with cycles, but you are using internal (screenshot). $\endgroup$ – p2or Sep 10 '15 at 11:58
  • $\begingroup$ I edited my question. How to get the composite output I want (the combined render layers) ? $\endgroup$ – Old Man Sep 10 '15 at 13:12
  • $\begingroup$ You want to have both cubes, right? Please try to explain what is wrong with 3pointedit's answer and what you don't understand exactly. $\endgroup$ – p2or Sep 10 '15 at 13:27
  • $\begingroup$ done. see my added comment $\endgroup$ – Old Man Sep 10 '15 at 14:25
6
$\begingroup$

It could be that you are not actually providing the compositor with any transparency. The alpha output socket from the scene node will just be a solid white unless you check the following properties:

Blender Internal: Turn on Shading > alpha > transparent, in render properties.

Cycles: Turn on film > transparent, in render properties.

$\endgroup$
  • $\begingroup$ Thanks for explaining how to work with transparency / alpha channels. Maybe I was not very clear in my question. I have now added a new picture showing the composite layer in cycles blender. Why is only one render layer in the composite layer ? I want both render layers in the composite layer. How to do that ? $\endgroup$ – Old Man Sep 10 '15 at 14:23
  • $\begingroup$ @JanScherders Simply because your images (see the render layer preview window) are not transparent. As I suggested, read this post carefully. Here is a blend, open it and hit F12: blend-exchange.giantcowfilms.com/b/488 $\endgroup$ – p2or Sep 10 '15 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.