2
$\begingroup$

This question already has an answer here:

I'm trying to create a grass effect on a small landscape I've created. My current approach is to use a hair particle system, and style the hairs to look like grass. I've got a simple particle system added, and adjusted a few settings (note: I haven't made the grass green yet. It's just grey for now), but for some reason the particles don't go on certain parts of the mesh: Missing Particles You can see that to the left of the "lake" there is a lot of missing particles, in triangular areas. Although this screenshot was taken in rendered 3d view, it also has the same issue when I press the render button and do a "true" render. Here's some of the geometry: Geometry

Any ideas why it isn't completely covered with particles?

$\endgroup$

marked as duplicate by PGmath, Community Sep 10 '15 at 2:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ Do you have any modifiers on the object. $\endgroup$ – PGmath Sep 10 '15 at 0:46
  • $\begingroup$ Subdivision surface and particle $\endgroup$ – markasoftware Sep 10 '15 at 1:17
  • 1
    $\begingroup$ Did you check use modifier stack under the particle settings? $\endgroup$ – PGmath Sep 10 '15 at 1:20
  • $\begingroup$ facepalm wow, I didn't see that option. This is the first time I've ever used particle systems, so I didn't really have any idea what I was doing. Thank you! It works after enabling that option. If you post that as an answer I'll accept it $\endgroup$ – markasoftware Sep 10 '15 at 2:02
  • $\begingroup$ No worries! You are definitely not the first person to overlook that setting. $\endgroup$ – PGmath Sep 10 '15 at 2:15
1
$\begingroup$

Make sure use modifier stack is checked under the emission rollout of the particle settings.

enter image description here

$\endgroup$
  • $\begingroup$ Please do not copy paste entire answers. Just mark it as a duplicate. $\endgroup$ – David Sep 10 '15 at 18:50
  • $\begingroup$ @David Sorry, I actually just used the same screenshot. I wrote the answer without a screenshot and then remembered my old answer and decided to use the same picture. $\endgroup$ – PGmath Sep 10 '15 at 18:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.