1
$\begingroup$

I admit I am a newbie at Blender. (sounds a bit like alcoholic anonymous).

I need to find a suburban scene, (a few buildings, roads, maybe some street signs).

I found this one:

http://tf3dm.com/3d-model/environment-23742.html

Which will do in a pinch.

Download formats are FBX and OBJ (and an MTL file).

But with Blender 2.7, when I import I do not get the textures.

I have gone through the 7 hours of http://www.lynda.com/Blender-tutorials but this one is a bit beyond me. I am probably missing something basic.

What I want is something quick (in terms of my time) and free, since this is a proof of concept.

(Here is what I get with OBJ import, and two hemisphere lights behind the camera).

enter image description here


UPDATE

Ok, I tried again with FBX, textures in same directory.

With the OBJ import, all I had to do was set the VIEWPORT shading to texture.

With the FBX (you can see below) if I set the viewport shading to RENDER it I see the textures, but not with Texture rendering (as I said, I am a newbie). There seems to be a odd difference between the handling of OBJ and FBX. but it is good to get this going.

Unfortunately, this model does not work for me, since I need export to Babylon.js, and that does not work well with this sort of TGA and multi-texture format files (see the firestorm I started in the Babylon.js forum)

http://www.html5gamedevs.com/topic/17001-missing-manifest-from-blend-exporter/

enter image description here

$\endgroup$
1
$\begingroup$

I have downloaded the files you linked to. I extracted the zip file and (using blender 2.75) used file, import FBX and opened the FBX, hit F12 and no textures.

Closed blender.

Within the zip, there is a .RAR file 'textures.rar'. I extracted that file in the same directory as the FBX and repeated the above process. Textures where showing up when rendering.

$\endgroup$
  • $\begingroup$ Very strange. I am using Blender 2.75a, I tried the same thing (extracted the RAR to both a subdirectory called /textures, and also to the same folder as the FBA (about 9 tga files). Then did the import and changed the viewport to texture display. No good. But if I import the OBJ, then it works fine. $\endgroup$ – Dr.YSG Sep 9 '15 at 16:04
  • $\begingroup$ I'm on windows, what platform are you on? $\endgroup$ – Kristof Meirlaen Sep 9 '15 at 17:53
  • $\begingroup$ screenshot after import $\endgroup$ – Kristof Meirlaen Sep 9 '15 at 18:04
  • $\begingroup$ I am on windows 7 SP1, Very strange. Also. My lighting was all off. I added some HEMI lights, but as you can see it still is not what you are getting. I assume that FBX import is better. $\endgroup$ – Dr.YSG Sep 9 '15 at 19:29
  • $\begingroup$ Did you unzip to the textures folder, or to the same folder as the FBX? $\endgroup$ – Dr.YSG Sep 9 '15 at 19:29
0
$\begingroup$

If you edit the .mtl file (it's in plain text), you will see that it links to material files that are in a specific folder. E.g. map_Ka E:\Work\Sale\3D\Building\City_Building\textures\building03_c.tga It may be that you have to edit these to point to the correct path where you have put them.

I've had loads of grief with .obj and .mtl files from 3rd party sources over the years. Some work perfectly, others do not. I suspect it's something to do with the package being used to export them. Additionally, some people upload the .obj files but forget about (or don't know about) the .mtl file and the required texture files. (Some people don't upload the texture files because they are copyright, so it's a bit unfair of them to show samples with the textures in place.)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.