It seems that when exporting layers as png images in Photoshop, some elusive semi-transparent pixels may be saved as white and become quite apparent when imported as planes into blender.

enter image description here

This could be easily remedied by erasing their alpha in the texture paint mode; however, transparent becomes white:

enter image description here

This makes it very hard in most, and impossible in some, cases to tell where these stray pixels are and when I've gotten rid of them ("erasing alpha" is basically painting "white" over white).

Any way to get rid of the transparent white by either replacing it with a different colour, hiding it completely or replacing it by some Photoshop-style grid?

  • 1
    $\begingroup$ Is Color and Alpha in Channels of the image to Draw selected ? "Erasing alpha" makes background colors to appear, so if there is no alpha, then white will be instead. $\endgroup$ – Mr Zak Sep 7 '15 at 21:07
  • $\begingroup$ Where do I find channels of the image to draw? $\endgroup$ – User1291 Sep 8 '15 at 7:38

In your material settings for your image texture - the material in the Shading tab of the properties panel needs to have Z Transparency turned on for the GLSL viewport to allow you to 'see' the erase alpha as the background showing through.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.