I'm using the latest build of Blender (2.75a). When I use the fly mode function (Shift+F) I am unable to control the view of the camera with the mouse. I tried uninstalling and reinstalling, but that didn't work. This function worked fine the other day, but now it won't work. Any help would be appreciated! Working in Blender hasn't been more convenient since I've been using Fly Mode.

I'm running Yosemite, and my mouse works with everything else but controlling the camera's direction of view in Fly Mode.

Fixed! The menu bar above the timeline was placed too high for my mouse's movements to be read.


closed as off-topic by p2or, iKlsR Sep 12 '15 at 3:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is too localized in its current form and is unlikely to be applicable outside of a very narrow context. Consider broadening the scope of this question in order to make it more useful for future users of the site." – iKlsR
If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ Did you worked with the latest official build (2.75) also "the other day" when things were fine? I'm using Windows and fly mode is ok. What's your OS? $\endgroup$ – Carlo Sep 6 '15 at 23:22
  • $\begingroup$ Thank you for responding. Yes, it worked when I was using the latest version. I'm running Yosemite. $\endgroup$ – Avispa Sep 6 '15 at 23:33
  • $\begingroup$ Can you change the camera's position with the keyboard? And toggling the gravity? $\endgroup$ – Carlo Sep 7 '15 at 0:05
  • $\begingroup$ Yes. no problems with either of those. Everything works in Fly Mode except for the movement of my mouse guiding the camera's view. Even the scroll function works (the speed change). $\endgroup$ – Avispa Sep 7 '15 at 0:10
  • $\begingroup$ Oh I found the problem! The Menu Bar above the timeline that lists the options "View", "Select", "Add", and "Object" was set too high by default-- the fly mode wasn't reading my mouse movements because they were outside the menu's navigation. Thanks again, Carlo! $\endgroup$ – Avispa Sep 7 '15 at 0:25


The mouse's movements can't be read in Fly Mode when the menu is like the example in red.

For this to work I also have to hide the right side of the menu like

so: http://puu.sh/k2Bl3.png

  • $\begingroup$ Thanks! I'll play around with this and see if I can reproduce what you experienced. $\endgroup$ – Mentalist Sep 7 '15 at 2:31
  • $\begingroup$ I made an edit to the answer that was necessary for this to work. That's the last of it! $\endgroup$ – Avispa Sep 7 '15 at 3:08
  • $\begingroup$ New info! See the edit I made to my answer under "Update". I think your feedback helped with getting this bug resolved. :-) $\endgroup$ – Mentalist Sep 8 '15 at 23:00

Yes, it is a bug, specific to Mac. Please see the bug report that has been filed. Basically fly mode used to work fine on Mac in previous versions and now it doesn't, or at least not all of the time. Seems it's intermittent and nobody has been able to figure out the cause yet. But if you chime in on the bug report page it will further validate the issue, and maybe there you can read what other people have observed and get some ideas for how it can be reproduced consistently. Once it can be reproduced consistently, devs can hopefully isolate the cause and get it fixed.


The bug has been fixed! So if you download the latest build you should be good to go! Seems it was a problem with calculation of cursor location on Retina Display Macs. See the new comments in the bug report I linked to for details. Avispa, your workaround seems to evade the problem by readjusting the layout in a specific way - but if you actually want it to be fixed, get the latest build.


Not the answer you're looking for? Browse other questions tagged or ask your own question.