8
$\begingroup$

The problem, and what I've tried so far

From the screen shot you can see that sky-blue from the mist color is leaking through the trees due to white spots that are occurring in the mist pass on the tree particles. I have no idea what is causing these anomalous white patches in the mist pass.

White areas showing up in mist pass

I created this very simple file to illustrate the problem, but the tree itself was pasted in from a larger project and was created using the Sapling add-on then converted to a mesh for particle use. I gave it a new and very basic leaf material, but the problem persisted, so I believe it is not a problem originating with the material. I tried increasing the number of bounces, thinking it was an issue with the transparency of all the leaf planes, but that didn't help either. I tried flipping the normals of the leaf planes, as well as checking "Double Sided" in the Mesh Context, but it made no difference. To clarify, I am using Cycles.

A similar issue

I found another question here that at first looked to be the same, but that person was using Blender Internal, and using hair particles instead of object particles. The solution is their case was specific to Blender Internal, it seems.

More details

When I tried reproducing the problem using simple cube particles I could not. It appears there is something different about these trees. It's quite puzzling. And notice that some parts of the tree have the correct mist depth while others have the problem. Also note that the problem does not show up in viewport rendering, only in the final render. It's not specific to particles either.

Thanks!

$\endgroup$
8
$\begingroup$

Multiple transparent planes with low Max Transparecy Bounces

The "Tree1" object is made by multiple overlapping planes. Their shading properties comes out from a sharp Mix of a Transparent shader and a Diffuse shader.

As there are multiple intesection and your Max Transparency Bounces is set to 8, light can't filter trough all the planes.

enter image description here

We can clearly see this by giving to the material a full Transparent shading.

enter image description here

More Bounces leads to the expected shading behaviour:

enter image description here

Now that the shader works as expected, you'll have no issue in Mist pass calculation:

enter image description here


Thought about Mist pass caluculation. I didn't find any evidence of the following lines in documentation, so take it as my (current) opinion, and feel free to discuss about

When Light reaches the max number of bounces stadted by the Light Path settings the simulation is "over". This means that the path tracer cosider the light information in the same way as the light would have reached the background. And as is considered "background", its mist pass value will be the higer possible (1=fullwhite).

$\endgroup$
  • $\begingroup$ Awesome! Thank you. I had tried increasing some of the Light Paths values, but clearly I didn't raise them enough. Well, render times are going to be a bit longer but at least it's going to look right! Looking at your screen shots of my material I just noticed I left in a mix node that serves no purpose... that's embarrassing. Anyway, that troubleshooting technique of trying out an all-transparent material is smart and I will use that from now on if I suspect transparency bounce issues. $\endgroup$ – Mentalist Sep 6 '15 at 12:40
  • $\begingroup$ I agree with what you added about the mist value defaulting to white upon reaching the bounce limit for transparency. That makes perfect sense. $\endgroup$ – Mentalist Sep 6 '15 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.