3
$\begingroup$

I have encountered a problem where my driver would not show in the graph editor while viewing Layer 1 and layer 11. I discovered that moving the wheels in question would show the driver in the graph editor in layer 3? Although the driver worked in the said layers but did not show.

enter image description here

enter image description here

$\endgroup$
4
  • $\begingroup$ Welcome to the site :) We like to keep to one question per post here, to keep things organized and on-topic. If you have multiple distinct questions, you are more than welcome to create multiple posts. $\endgroup$
    – gandalf3
    Commented Sep 5, 2015 at 20:31
  • $\begingroup$ There isn't a built-in way to upload files at the moment, but you can use blend-exchange. To request clarifications etc, it's preferred to use comments. Edits are for clarifying or adding info to your post. $\endgroup$
    – gandalf3
    Commented Sep 9, 2015 at 5:55
  • $\begingroup$ Ok thx for the info. Will comment when I have succeeded. $\endgroup$
    – PeteL900
    Commented Sep 10, 2015 at 15:02
  • $\begingroup$ Managed to upload it. Just using materials to see what I'm doing. $\endgroup$
    – PeteL900
    Commented Sep 10, 2015 at 15:33

2 Answers 2

3
$\begingroup$

You have Show only selected enabled in the graph editor:

enter image description here

While this setting is enabled, only drivers and fcurves belonging to selected objects will be shown.

$\endgroup$
2
  • $\begingroup$ Ok thx, but it still doesn't show when I untick it as in pic. Doesn't show in f-curve either even tho I have the selected item highlighted. i.sstatic.net/kyROy.jpg $\endgroup$
    – PeteL900
    Commented Sep 8, 2015 at 8:24
  • $\begingroup$ @PeteL900 Hm.. Is it possible you could upload your .blend? $\endgroup$
    – gandalf3
    Commented Sep 8, 2015 at 9:51
2
$\begingroup$

I had a pretty similar problem as well. What gandalf3 wrote is definitely correct. I just want to add the following:

Instead of disabling the Selected Only button (little Cursor Icon) you could as well enable the Invisible Objects button next to it (Ghost Icon).

Other than flooding your list of drivers shown on the right with all existing ones, you still only see, what you want to see. This is especially helpful when applying drivers to empties, which might not show up, if you have this button disabled.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .