1
$\begingroup$

It seems there are many tools, such as the knife tool, that cause the viewports to lock up when you are "in" the tool. By "lock up" I mean that while in the tool I cannot rotate, pan, or zoom the view. This would be super handy and seems like a no-brainer. Thanks for your help! -Ben

$\endgroup$
4
  • $\begingroup$ What is the problem to rotate / grab the view while in the Knife tool by pressing MMB / Shift + MMB ? You can also zoom as usual, by scrolling the wheel. $\endgroup$
    – Mr Zak
    Sep 4 '15 at 21:27
  • $\begingroup$ That's what I mean. I expect I SHOULD be able to do that, but I can't. I say the view locks up and the normal mouse navigation you are describing does not work as long as the tool is active. $\endgroup$
    – Ben Mora
    Sep 4 '15 at 21:34
  • $\begingroup$ I'm not sure where the problem is, as it works for me pretty well (versions 2.74 and 2.75 ) $\endgroup$
    – Mr Zak
    Sep 4 '15 at 21:38
  • $\begingroup$ Wait, silly me... I've been using not a regular mouse but a 3D mouse (3Dconnexion) and got so used to it that I forgot I was doing it. I just tested with regular mouse and it IS working as I would expect. So I guess the issue is that this 3D mouse stops manipulating the view while the tool is active. I guess there's not likely a solution for that as it is a third-party issue. $\endgroup$
    – Ben Mora
    Sep 4 '15 at 21:43
1
$\begingroup$

I figured out my problem. I am using a 3Dconnexion 3D mouse and it does not manipulate my view while a tool is active. The normal mouse/keyboard ways of rotating etc do still work as expected while a tool is active.

$\endgroup$
1
  • 1
    $\begingroup$ I would submit that as a bug, you shouldn't have to switch to a normal mouse. 3dmouse support is programmed into blender so I expect the issue is there. $\endgroup$
    – sambler
    Sep 5 '15 at 9:15
0
$\begingroup$

Actually I am facing the same problem. However in my case it's related to the modelling settings I am using (industrial standard, with alt + left mouse button for tumbling). It's not possible to tumble while using the knife tool. I sincerly hope this issue will be fixed in Blender 3.0 ;-)

$\endgroup$
1
  • $\begingroup$ This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review $\endgroup$
    – Gorgious
    Oct 14 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.