7
$\begingroup$

I saw this tutorial on Blender Nation that deal with creating Minecraft animations in Blender. After following several links, I finally came up with the file and downloaded it.

I could edit the images that were used to texture the models. However, when I wanted to disable anti-aliasing/sampling, I discovered that the textures are not linked to their objects in the usual way (i.e., through the Textures tab in the Properties panel). In fact, I have not been able to find any link between the textures and the objects that they adorn.

What is going on here? Am I just missing something blindingly obvious?

$\endgroup$
7
$\begingroup$

The reason for this is that none were created, the author simply unwrapped the models and changed the view to Textured.

Here is a quick example using the texture I unpacked from the file. As you can see, the cube doesn't even have a material. This is perfectly legit in Blender but really bad practice as it pertains to asset management etc.

enter image description here

Since the objects are already unwrapped, to fix it, just create a texture and change Coordinates under Mapping to UV. For a bit more information on correct UV mapping, see Blender UV mapping error

$\endgroup$
  • 7
    $\begingroup$ It is also worth noting that this won't render by default. It will only show in the 3d view. It renders because Face Textures is ticked under the material options. $\endgroup$ – iKlsR Nov 9 '13 at 16:42
  • 1
    $\begingroup$ Thanks for your comment iKlsR, it helped me in some simmilar project and spared me a lot of time. $\endgroup$ – Zéiksz Jul 9 '15 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.