4
$\begingroup$

I combined two action strips in the NLA-editor but the forward movement fades in (red curve in the image below) I would prefer to have this linear. Where can I change this behaviour? Action blending and extrapolation doesn't seem to have an effect.

enter image description here

$\endgroup$

1 Answer 1

4
$\begingroup$

The relevant setting is Blend In/Out. To ignore keyframes in strips below the active one, turn off Auto Blend In/Out, and set both blend values to 0:

1a

More generally I suggest, for bones that will be animated in a layer, to avoid keyframing it in strip actions in all other layers. Or do it in such a way that the strips don't overlap. That'd save you some headache when the animation mixing gets more complex, especially if there are semi-overlapping action strips. Not used carefully, action blending could cause jerky movement that's hard to tweak.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .