16
$\begingroup$

Sometimes freestyle renders will have gaps in the lines:

enter image description here

Closer up:

enter image description here

What causes this and how can I prevent it?

$\endgroup$
  • $\begingroup$ You can improve the result by giving te stroke a round end. $\endgroup$ – user23382 Apr 4 '16 at 14:23
6
$\begingroup$

Try the following:

  1. Make the mesh smooth (I guess this has been already done in your scene).
  2. Enable the Face Smoothness option in Properties > Render Layers > Freestyle.

A detailed explanation of these settings can be found here.

$\endgroup$
  • $\begingroup$ This seems to work :) Could you explain what you mean by "Make the mesh smooth"? (smooth shading? physically smooth?) $\endgroup$ – gandalf3 Nov 9 '13 at 1:50
  • $\begingroup$ By "make the mesh smooth" I meant smooth shading. This way mesh vertices may have multiple normals, from which Freestyle can compute smooth silhouette lines that do not exist as edges in the original mesh data. $\endgroup$ – T.K. Nov 9 '13 at 12:35
4
$\begingroup$

It is mainly caused by toggling "Chaining" feature in the Freestyle Lining Style panel, if you are sure it's not caused by any Freestyle modifiers.

If so, to prevent that, you may simply toggle "Enable Chaining" off, or just include "Contour" by toggling it in the Edge Types list. (But make sure "Same Object" is not toggled, which is right below the "Enable Chaining" checkbox.)

$\endgroup$
  • $\begingroup$ This seems to remove some of the gaps, but not all: pasteall.org/pic/62245 $\endgroup$ – gandalf3 Nov 8 '13 at 20:48
  • $\begingroup$ Agree. user1561's way works better on your scene. $\endgroup$ – Leon Cheung Nov 9 '13 at 6:23
0
$\begingroup$

For Text (fonts)

  1. Convert the text to a mesh using Alt + C in 3D View and picking "Mesh from Curve/Meta/Surf/Text"

converter menu

  1. Turn on "Face Smoothness" in Properties > Render Layers > Freestyle

Face Smoothness setting

Before:

before

After:

after

Note: this might still not be enough, you might be forced to apply "Smooth" Faces in Edit mode (press TAB in 3D View to switch) in the Shading/UVs sidebar (press T to open).

Since this might screw up the rendering of the model, you might want to duplicate the model and render the copy on another layer.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.