0
$\begingroup$

I am trying to install various addons to no avail. I have tried many, and they can't all be buggy.

I go to settings, click install from file, choose file, then select install from file again. Search for the addon and it isn't there. What am I doing wrong? I have also copied all of the content from the downloaded file and put it in a new file and saved as name.py. Still nothing shows up. And yes, the document starts with what it should start with, not html.

$\endgroup$
  • $\begingroup$ What Supported Level is selected at the top left? $\endgroup$ – CoDEmanX Sep 2 '15 at 21:21
  • $\begingroup$ I'm not sure where you mean. There are no numbers top left. I am using version 2.75 on a Mac. $\endgroup$ – Chris Churchill Sep 3 '15 at 19:38
  • $\begingroup$ In the user preferences window, addons tab, below the search box and above the categories: blender.org/manual/_images/Userpref_addons_en_oct20_2013.jpg $\endgroup$ – CoDEmanX Sep 3 '15 at 20:51
  • $\begingroup$ Ah i see. I looked on all of them and couldn't see it. I just put it directly in to the directory and it is now showing, but it is saying that there are two versions of it installed and can't launch. I am uninstalling the program and then putting the Haddon in manually. Hopefully that will work. $\endgroup$ – Chris Churchill Sep 3 '15 at 21:06
  • $\begingroup$ Note that there are two folders for addons (at least on Windows), in Blender installation directory and in your user folder (on Windows in %appdata%). The addons Blender ships with are in the former, addons installed via the interface copy them to the latter. $\endgroup$ – CoDEmanX Sep 3 '15 at 21:08
0
$\begingroup$

If your addons are zip files, then it is best to unzip them and place them in the addons directory. For Windows it is (where you installed Blender)/Blender Foundation/Blender 2.75/2.75/scripts/addons directory. Put your addons there, then restart Blender and it will show up in the User Prefs.

$\endgroup$
  • 1
    $\begingroup$ It's not necessary to restart Blender, F8 should do the trick. $\endgroup$ – CoDEmanX Sep 2 '15 at 21:20
  • $\begingroup$ I just did what you said and now it is showing, but it says that two versions of it are now installed and I can't use it. What I am going to do is uninstall the whole program and reinstall it. Then just put it straight in to the directory like you suggested and hopefully it will work then. $\endgroup$ – Chris Churchill Sep 3 '15 at 21:03
  • $\begingroup$ It worked. I also had to remove the Haddon from my library user section on my Mac too. Thank you for your help :) $\endgroup$ – Chris Churchill Sep 3 '15 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.