4
$\begingroup$

I have a very fast computer and i'm trying to render out this scene (just in the viewport, as i'm making stuff, so not the final product) when when I turn the view a little in certain directions it all goes grey, and where i move after that everything is grey (In render view/render. All the effect are just simple texture/alpha tweakingenter image description here, what is the issue here?

Here is the outliner and i thries the reset it worked once, but couldn't get it to do it againenter image description here

Actually I did get the reset to work a few more times but it only seems to work on sporadically, but it doesn't seem to be an alpha issue, because there has been nothing blocking the view for the majority of the failures ( like the first pic, there is no transparent plane blocking that view, or anything[That i'm aware of])

The File-

$\endgroup$
  • 1
    $\begingroup$ Try adding some lamps and also could you post a screenshot of your outliner $\endgroup$ – Igor Tatarnikov Sep 2 '15 at 9:48
  • $\begingroup$ If you restart the viewport render after it turns grey (Z, then Shift Z), does that fix it? Is it possible you have duplicate objects in the same places (causing Z fighting)? $\endgroup$ – gandalf3 Sep 2 '15 at 17:57
  • $\begingroup$ And do you mean more lamps? I thought the same thing and just put in 1 sun and a hemmi, do you think i need more just to see? (Not going for final lighting yet, i just wana see what im doing) $\endgroup$ – Steven Sep 2 '15 at 19:58
  • $\begingroup$ As to lamps - it depends on their options and location (if Sun lamp). But in most cases it's enough default lamp energies and 1-2 lamps to see the scene. The same "it depends" one may say regarding to render options. So it may be easier to resolve this question if copy of your .blend file provided. You may use blend-exchange for that $\endgroup$ – Mr Zak Sep 2 '15 at 20:03
  • $\begingroup$ Note that all your objects appear to have inverted normals $\endgroup$ – gandalf3 Sep 2 '15 at 21:22
1
$\begingroup$

I think I have found your problem. I have a very fast computer as well, and the same grey thing happens too, but not very often. To trigger the grey, I had to move around very fast and "use up a lot of power". As fast as your computer may seem, it still has a max.

But here are some things you could try:

  1. File > User Preferences > System > and check "VBOs".
  2. Try to moving some objects to different layers, oddly enough Blender calculates each layer separately. (There is an article about that: http://www.blenderguru.com/articles/how-to-render-a-complex-scene-without-crashing/)
  3. If all else fails, you could try reducing the number of complicated materials and vertices.

Hope that helps!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.