I am modifying a pre-made armor mesh. The armor has some holes in it that I would really like gone. So I deleted the faces with the holes and replaced them with new faces. The problem is that the UV map does not add the new faces, so the new faces are not being textured with the rest of the armor. I know I can unwrap the new section, then patch the UV map manually, but I would prefer a more automatic way since it would probably look a bit better.

Here are the holes I don't want in the mesh. enter image description here

Here is the mesh after I replaced the old faces, and used unwrap on the new ones. enter image description here

I am pretty new to Blender and I am using an outdated version, but any advise would be greatly appreciated. Thank you.

  • $\begingroup$ You wrote .... I am using an outdated version ....... Please use a reasonably new version in the future. Its probabaly an unnecessary situation for you and the reader. If you state your reasons for using an outdated version I feel confident someone can convince you to do otherwise. $\endgroup$ Commented Aug 31, 2015 at 23:40
  • $\begingroup$ Well, I'm using Blender exclusively for modding armors for Fallout 3/New Vegas. Apparently the Import/Export options only work reliably with older versions of Blender/Nif scripts/PyFFI/Python/Nifskope. I could probably get the new versions to work, but I don't really feel the need mess with it at this point. So I guess I am stuck with it for now. $\endgroup$
    – Skip1819
    Commented Sep 2, 2015 at 2:41

1 Answer 1


First select the original UVs and pin using P shortcut and enable Live Unwrap

Then in the UV/Image Editor move one of the vertices of the new created faces and it should snap the faces in the right position.

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .