5
$\begingroup$

I'm new to blender and I need it to stabilize a panoramic 360° video. I found this addons https://github.com/dfelinto/Panorama-Tracker I correctly stabilzed the video and I can correctly see it in the 3D View window but I can't find a way to apply that stabilization in the node editor view so I can't render it. I'm surely missing some steps. I can't understand if I should connect something between Movie clip and Viewer nodes and in that case what I should connect.enter image description here


Thanks guys for helping me. Because of 360 video I need a stabilization that doesn't crop the video or I'll be not able to exactly connect the left and right borders of the image. For this reason I installed the panorama stitcher addons. I need to track two points, set as Focus and Target tracks and It will create a Panorama camera. The correct stabilization is what you can see on top of the screen, that image with yellow curvy line. But the only thing I'm able to get in the viewer and in the file rendering is what you see at the bottom, with the stright yellow line. Even connecting the Stabilize 2D, I had yet tried too, I can't get the rendering like the upper view. I can't find the "Panorama camera" in filters, distort or whatever. I'm stucked here. Here ( https://vimeo.com/75889844 ) he explain how he did it but the missing steps to the final rendering is what I need. Thanks a lot enter image description here

$\endgroup$
  • $\begingroup$ did you install movie tracking: panorama tracker - add-on? $\endgroup$ – user31238 Oct 7 '16 at 11:05
2
$\begingroup$

You have to connect the image result of the compositing to the composite node as well as the viewer node to see anything in the final render. The viewer node just controls the compositor backdrop.

$\endgroup$
  • $\begingroup$ Thanks, but if I can't see it stabilized in the viewer it will not be rendered stabilized. I captured the screeen this to show the discrepancy between the upper stabilized and the final I'm going to render not stabilized. Or am I wrong? Thank you. $\endgroup$ – mmm517252002 Aug 30 '15 at 17:42
1
$\begingroup$

You can use the Video Sequencer Editor, no need of compositing nodes.

After having stabilized your clip, open the Video Sequence Editor, then hit SHIFT + A over the timeline, and choose your clip into the Clip submenu.

Then, in the clip's properties (N) panel, find the checkbox Stabilize 2D Clip, located in "filter" section:

enter image description here

Make sure your render settings are set up correctly, according to your needs (resolution, fps, output file and codec...) And finally, just hit Render Animation button.

$\endgroup$
1
$\begingroup$

In the compositor add a Stabilize 2D node (Add->Distort->Stabilize_2D) and select the tracked clip to be used for stabilization.

enter image description here

$\endgroup$
0
$\begingroup$

It's something with how the add-on sets things up in blender.

Once the add-on is installed and enabled in blender, in the properties panel, under "post processing", you need to disable "sequencer".

$\endgroup$
  • 1
    $\begingroup$ Can you edit your post and add an image to demonstrate what you mean? $\endgroup$ – Scott Milner Jul 31 '18 at 21:20
  • $\begingroup$ Yes, good idea! :) I will do it tonight. $\endgroup$ – Sakrecoer Aug 1 '18 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.