3
$\begingroup$

I have a rather simple glass material on a wine glass model, it renders perfectly fine in preview, but in final render it gets these black artifacts around edges.

I've checked other threads and tried tweaking the near/far clip but it doesnt seem to affect the issue. I've also upped the light paths to full global illumination.

Example: Preview render to left, final render to right

Material and render settings: Material to the left, render settings to the right

What could be the cause of this? Any help appreciated.

$\endgroup$
2
$\begingroup$

The problem was smooth shading, as pointed out by Igor Tatarnikov and Hexbob6. I needed to apply an edge-split modifier to the problematic geometry to fix the issue.

See Why does the Minecraft-texture have black/dark borders in Cycles?

$\endgroup$
0
$\begingroup$

Also try the setting in finalrender for number of refraction passes, A glass needs 4 at least. increase and check if improved.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.