2
$\begingroup$

I've imported some svgs, converted them to meshes, and I'm trying to stamp-cut one using the other.

Essentially, I have two cookie cutter meshes (no thickness, but has depth) at the same location. I've z-rotated one of them a bit, left the other, and now I want the intersection of the two.

I tried the boolean modifier, but it says it can't complete the operation. I also tried mesh > faces > intersect, also didn't work.

Any help is appreciated.

enter image description here

$\endgroup$
  • $\begingroup$ Boolean modifers con fail if the meshes are not "clean" enough: self intersecting faces, double vertices, wrong normals... If you are not able to make it work, I would suggest to upload your blendfile. Consider also if Project Kinfe command can be useful for your situation. $\endgroup$ – Carlo Aug 29 '15 at 8:38
  • $\begingroup$ @Carlo - I've added a screenshot, and updated. $\endgroup$ – Karric Aug 29 '15 at 13:13
  • 2
    $\begingroup$ Probably filling end faces of the "cutter" object and setting the Boolean for the object to cut to Difference may help (if the meshes have clean topology as is already mentioned). $\endgroup$ – Mr Zak Aug 29 '15 at 13:36
  • $\begingroup$ Could you describe the screenshot a bit? Look like you have one object, not two. I would suggest to split them, close caps (bool work with volumes) and than use the modifier. Avoid coplanar faces. $\endgroup$ – Carlo Aug 29 '15 at 16:41
1
$\begingroup$

Boolean modifier is the correct option. It is failing because your meshes are not closed. Booleans do not work on open meshes. Select the ending loops of your meshes and press F to add a face. You can delete it again after the boolean has run.

$\endgroup$
  • $\begingroup$ I've added a screenshot, and updated. $\endgroup$ – Karric Aug 29 '15 at 13:13
0
$\begingroup$

You can use the Knife project tool :

1- select the one to cut with (in object mode ) and click Shift+1/3/7 to go in local ortho view so only the outlines are visible.
2- press Shift and select the other object and switch to edit mode.
3- deselect all and use Knife project and enable cut through.
4- reverse the selection with Shift+I and delete the vertices.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.