In a blender cycles project I am working on, I made a scene that includes grass, and it all renders fine, but there is a rather serious green tint in the shadows under the deck. The lighting is a flattened sphere with the normals turned inward and a sky texture node applied to it. The grass has a simple dark-green hair texture node. Farther out, I have a flat plane that is also green, with a noise texture and color ramp to generate a sort of clumpy grass look.

I definitely don't think I would see a green tint in real life, but I don't think a camera would have it either. I thought it was kind of interesting that it had such a sunrise/early morning feel to it when the sky texture has the sun straight overhead.

Underneath the deck

Light Sphere nodes:

  • Sky Texture - Preetham, Turbidity 2.2, Vector from Texture Coordinate: Object Vector
  • Emission texture - Strength: 1, Color from Sky texture

Grass nodes:

  • Hair BSDF - Color: Dark green, both roughness set to 1.0.

Grass plane nodes:

  • Diffuse BSDF - Color: varied dark green, roughness: .358
  • $\begingroup$ I think screenshots would be better for node setups or, alternatively, you can upload the blend to blend-exchange.giantcowfilms.com $\endgroup$ Aug 28, 2015 at 13:19
  • $\begingroup$ There, hopefully that is a little more clear. They're actually very simple, and I'm mainly putting them there for the few settings that pertain to this. $\endgroup$ Aug 28, 2015 at 13:35
  • 1
    $\begingroup$ "I definitely don't think I would see a green tint in real life, but I don't think a camera would have it either. " Actually this does happen in real life. We autocorrect it in our brain, but it's still there. Cameras also capture it - consider the photo here. If you use a color picker on the shadow under the overhang you'll find a very slight green cast. $\endgroup$
    – Adam Davis
    Aug 28, 2015 at 17:55
  • $\begingroup$ The funny thing is that I would never have noticed it if I hadn't rendered the house layer without masking it. It started rendering in the preview, and I was like "What's that green doing there?!". $\endgroup$ Aug 28, 2015 at 19:30

1 Answer 1


Limit light bounces

The green colour comes from the light that bounces on the grass and the grass planes. As no direct light hits that surface, it is been colored by the indirect light only (which in your case is green). Because the walls are almost white, the effect is even stronger.

This is a physically based behaviour. You can get more information by searching about "Color Bleeding".

enter image description here

Notice how the faces of the cubes inside the cornell box that don't get direct light gain the tint of the wall they are facing.

Try to enable diffuse direct&indirect render passes and examine them and dedermine where the green comes from.

Anyway you can get rid of that by for example limiting the number of light bounces of the plane material:

enter image description here

The ray depth node will assign an empty shader to the material if it has done more than 0 bounces (direct light).

enter image description here

You could also work on the light path bounces in the render tab, but using the material nodes will give you full control on the single material, while preserving physically based behaviour of others.

If you don't want to leave the physically based way, I would suggest to lower the saturation and the value of your grass plane and maybe make it less green, more brownish, as it would be in a real world. This is probably the real cause it looks so unnatural.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .