2
$\begingroup$

I'm new to Blender (but I've known Maya for years), and any help y'all can offer would be greatly appreciated!

I'm having a problem similar to the ones in these posts, but the solutions offered there haven't solved my problem:

I'm working with this model that my company bought for a project:

The mesh seems to be generated with a CAD program. It's not pretty; lots of long skinny triangles and whatnot.

I'll focus on one example of the artifacts I'm getting.

Here's what I mean about ugly geometry: ugly geometry shown in edit mode

When I render it with Cycles, it has dark areas: ugly geometry rendered darkly by Cycles

The mesh is ugly, but the normals are all pointing out and I've removed duplicate vertices.

Has anyone run into this before? I could really use a hand!

$\endgroup$
4
$\begingroup$

Thanks Denis! (I can't comment cause I'm new.)

I think I've got a good solution going:

Eh? Eh?

With the object selected, I went to the the Object Data tab of the Properties Panel, and unchecked Auto Smooth.

Then, like Denis suggested, I added an Edge Split modifier. I checked Edge Angle and set it to 180 degrees.

This will work for me. Does anybody have any other suggestions for future reference?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.