I have created a low poly mesh in Blender. Now I would like to texture it in a different program. Therefore I would need a high poly model. When I add a "Smooth" modifier, nothing happens, my model still looks blocky. I expected my model to become smooth and the jagged edges would go away:

enter image description here

Can somebody tell me how I would do this? Thank you!


2 Answers 2


To make it LOOK smooth, select the object, hit 'W' and select 'Shade Smooth'

To ADD POLYGONS, you can optionally select all faces (in face select mode) and hit 'W' then 'Subdivide' This will quadruple your face count. Once that's done, you might want to hit 'W' then 'Smooth' (which actually moves vertices to achieve a smoother mesh).

Or, you can go add a Subdivision Surface Object Modifier, adjust the 'view' and 'render' values until you like the mesh. Apply the modifier to get back to a fully editable mesh again.

  • $\begingroup$ I have used "w", then "Subdivide Smooth". $\endgroup$
    – tmighty
    Commented Aug 26, 2015 at 0:29
  • $\begingroup$ No, I have changed my mind. I am using the "Faces: Smooth" option. This gives me just the results I wanted. $\endgroup$
    – tmighty
    Commented Aug 26, 2015 at 1:17
  • $\begingroup$ Seriously how did you not know this 0.0 $\endgroup$ Commented Aug 26, 2015 at 4:17
  • $\begingroup$ Subdividing a triangle makes 4 faces - so it's always quadruple.. $\endgroup$ Commented Aug 26, 2015 at 12:12
  • $\begingroup$ @Jerryno thanks. Good catch. I'll update the answer. $\endgroup$ Commented Aug 26, 2015 at 14:24

I'm not sure I completely understand what you want to do, but try a Subdivision Surface modifier or a Multiresolution modifier. You can then "apply" the modifier to make the increased subdivisions permanent.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .